Ever since moving to 8.14.2 I get major docker issues

Creating a bug report/issue

Required Information

G_LIVE_PATCH_STATUS[1]=‘not applicable’

  • Distro version | echo $G_DISTRO_NAME $G_RASPBIAN
  • Kernel version | uname -a
    Linux DietPi 5.10.0-21-amd64 #1 SMP Debian 5.10.162-1 (2023-01-21) x86_64 GNU/Linux
  • SBC model | echo $G_HW_MODEL_NAME or (EG: RPi3)
    x86 VM under ProxMox
  • Power supply used | (EG: 5V 1A RAVpower)
  • SD card used | (EG: SanDisk ultra)

As soon as I run “dietpi-update” and it completes, docker becomes broken.

docker: Error response from daemon: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: error during container init: unable to apply apparmor profile: apparmor failed to apply profile: write /proc/self/attr/apparmor/exec: no such file or directory: unknown.

I am unsure why, I just roll into my backup and have stuck with the old version.
Have I configured docker incorrectly in the first place or is there a change in how this latest update works, requiring me to change something?

Thanks so much

This is a bug in Docker software and has nothing to do with DietPi. Using the forum search should have brought this up. :wink: DietPi-Software | Docker: Service fails to start after upgrade (AppArmor) · Issue #6126 · MichaIng/DietPi · GitHub

There was a workaround wasn’t there

# apt install apparmor


systemctl disable --now apparmor

I remember seeing it here somewhere as well

Not sure if it’s something new with docker or apparmor…apparently needs profiles or something

I guess it’s there to increase security between the host system and the docker containers to keep them from being able to run/modify stuff from the main os

Finally, Docker 23.0.2 has been released fixing the issue on x86 Docker Engine 23.0 release notes


Thanks for the update.
I opted, to not make any changes to mine, with the fixes included in this thread. As it seemed to me something didn’t seem right.

I’m on D.Pi v8.13.2
Docker version 20.10.23, build 7155243

What is the right course of action to upgrade the whole lot, without blowing it all up?
Thanks all for the hard work, it’s appreciated.

There is no relationship between DietPi version and Docker version. The whole issue was with Docker software and has nothing to do with DietPi. The only thing happen, DietPi triggered an update of Docker to version 23, where Docker broke some things. Now they fixed it finally. To update Docker, you could run apt upgrade or simply dietpi-update as it will include the same apt package update.

Thank you for the help.

As I thought may happen, now that the issues (not DietPi fault) are addressed, the regular update has entirely worked.

Really appreciate all the hard work.

1 Like