Ethernet not found after Buster to Bullseye upgrade

I’ve followed the steps in the HOW TO UPGRADE TO “BULLSEYE” blog post, but after reboot I haven’t been able to reconnect via SSH.

After attaching a screen I can see that the ethernet is no longer found, I’ve tried enabling wifi, but can’t do that without a valid network connection. I’m not sure what else to try?

During boot I see this error:

DEPEND] Dependency failed for ifup for eth0.

This is on a Raspberry Pi 3b+


I’ve swapped the MicroSD card into a Raspberry Pi 4 and have been able to boot with ethernet, so very strange. I’ll have to investigate further tomorrow why it’s no longer working on the Pi 3b+.

could you check following on the RPi3

ip l
ip a
ip r
ifup eth0

Thank you!

I’ve got it working in a Raspberry Pi 4 now, but will swap back to the original 3b+ tomorrow and check this.

Hi Joulinar,

I’ve swapped back to the Pi3b+ and once again the ethernet isn’t found, running your suggested commands I can see an enx[MAC ADDRESS] instead of eth0, does that help?

Could you share a screen shot pls.

Photo attached. Thanks for your help.

ok looks like similar issues as this

pls try the fix provided by our developer.

That has fixed it, thank you!