ERROR Shairport Sync install


I have a Orange Pi 0 with expantion board.
I install DietPi , i love it
I install SqueezeBox , SqueezeLite and i try to install Shairport Sync but don’t work .

I have this message :

Apt-get has failed: │
│ - Apt string = openssl libsoxr0 libavahi-client3 libtool │
│ libconfig9 libpopt0 libdaemon0 --no-install-recommends │
│ - Error code = 100 │
│ - Software Title = Shairport Sync: airplay audio player with │
│ multiroom sync │
│ - Apt log = /etc/dietpi/logs/dietpi-software_apt.log │
│ │
│ Please report this issue to DietPi (INCLUDING THE APT LOG) so it │
│ can be investigated. │
│ │
│ DietPi-Software will now exit.

i format my MicroSD card and install again DietPi but i have a same problem.

Please help me.

Thank’s by advance

Hello again

somebody fo respond me please

i really need to use Shairport Sync on my Orange Pi zero please


While not the same problem as listed above, I am also receiving an error when attempting to install Shairport Sync on my Raspberry Pi Zero W. The message I receive is this:

Unable to Install Shairport Sync: airplay audio player with multiroom sync is offline and/or unreachable.

Any help would be greatly appreciated. Thank you.

I see in the changelog that v160 addresses my error. Looking forward to its release. Thanks for the FAQ which pointed me in the right direction.

Can you give me the link for the FAQ please.

i open a issue on the Git :

i hope you solved the problem for me :wink:

The FAQ I used is pinned at the top of the Troubleshooting board:

The changelog is linked from there.

With the release of v162 I am now able to install Shairport-Sync, but am unsure how to configure it, or if it requires configuration. I, perhaps wrongly, assumed that it would work immediately upon installation and reboot, but none of my devices are able to see the Pi as an Airplay device. I have attempted to edit the shairport-sync.conf file, but to no effect. I have also tried to manually start the service, also with no change. I am using a Raspberry Pi Zero W and connecting via SSH on Wifi. Am I missing something very obvious, or should the Airplay point have appeared on my network after installation? My apologies if this is posted in the wrong location, or the answer is located elsewhere, as I have been unable to solve the issue.


Sharport-Sync should not require any additional configuration, unless 16bit output mode is not supported on the soundcard. Then config change required /usr/local/etc/shairport-sync.conf output_format = “S32”

Please check status of the service:

dietpi-services status

Which soundcard are you running, default RPi onboard?