Endless Loop on first boot on Pi 4

Hi, I’m trying to use the latest Pi image version 6.25 from the main download page on a Pi 4. The Pi 4 boot fine, but when I try to install software from the menu system, it does not install and brings me back to the menu system. If I try to exit, it will ask if I want to start with the minimal image, and if I say yes, it simply brings me back to the menu system again. I’ve tried flashing the image numerous times with the same result. Is there another version I’m supposed to use on a Pi 4? Thank you!

I think you overseen the “Install” menu entry at the bottom. Please scroll down with arrow keys after selecting the software titles to install, select “Install” there.

This is a known issue currently since the whiptail window is too small, not increased to match screen size. This is fixed with v6.26 but to become effective on first boot, we need to create new images, once v6.26 is released.

Hi, thank you…I’m not sure if the overscan is the issue I am facing. The “installer” does run, but it appears it first tries to do a “dry-run” of the installation, but it appears that is failing. When I try to Exit to the shell, it says I can’t because no software has been installed. I am trying to install Docker, NAA, Roon Extension Manager, Roon Bridge and Raspotify. Thanks!

The issue with the dialog size is that the method we use (tput lines) prints wrong fallback values when STDOUT and STDERR output streams are both redirected. On firstrun call of dietpi-software we redirect both, to split and write into a log file for debugging like in your second case.
What I just remember now, is that the tput output has been fixed with Debian Buster, thus should not be present on the current RPi image anymore. To check/compare:

tput lines
tput lines 2>&1 | tee

should both show the same output (the available console lines).

DietPi-Software does a dry-run with apt-doc package to check if general connectivity, APT lists and locks etc work well, before starting real installs. This one fails? Could you paste some screen or console print in case, to check what the exact error is?
Or paste the error log as mentioned above:

cat /var/tmp/dietpi/logs/dietpi-firstrun-setup.log

Btw you can always exit the script outside of a dialog prompt, so when it is processing, pressing crtl+c.

I tried again and this time, I only selected RoonBridge and it installed correctly and then I rebooted and installed the rest of the software I needed: Docker, NAA, Rapspotify and Roon Extension manager and it all worked. So, I’m up and running. Thank you!

We just found the reason why Docker can produce an error on first run installs on RPi:

  • The kernel gets upgraded on regular apt-get upgrade which we call before doing the installs.
  • This is due to kernel packages are not versioned on DietPi.
  • For the same reason the old kernel files are not preserved until apt-get autoremove but overwritten/purged directly.
  • Docker now tries to load some kernel modules during it’s service start which fails due to loaded kernel and installed kernel mismatch, hence /lib/modules/$(uname -r) does not exist, which is requires for modprobe to load modules.
  • Even that the Docker installer does not fail by this, any following apt-get install will fail as APT tries too finish configuring the Docker package first, which loads then to dietpi-software terminating.

We solved this with v6.26 by deselecting Docker install if the mentioned directory is missing and inform user to reboot first to load the new kernel.

Thanks for the awesome work on DietPi!