Enable serial ports on 8.20.1?

Creating a bug report/issue

Required Information

  • DietPi version | 8.20.1
  • Distro version | bookworm
  • Kernel version | Linux DietPi 5.15.93-sunxi #23.02.2 SMP Fri Feb 17 23:49:46 UTC 2023 armv7l GNU/Linux
  • Architecture | armhf
  • SBC model | NanoPi NEO (armv7l)
  • Power supply used | a power supply
  • SD card used | 32gb SanDisk ultra

Additional Information (if applicable)

brand new install

On my other systems running 8.8.1 on Nanopi Neo’s which are gathering data from 2x serial ports (UART1 and UART2) I had no problem enabling the serial ports by adding in “overlays=usbhost1, usbhost2, uart1, uart2” to “/boot/armbianENV.txt”
I think I also had to set the serial port permissions

Now on 8.20.1 there is no armbianENV.txt file, Do I put this in the dietpi.txt file?

in dietpi-config you can enable the serial ports for a serial console but that’s about it.

for more information I am using node-red and a serial port node, It’s displaying as “Not Connected” and it’s saying it can’t set the baud rate at 9600 which I think is a permission issue.

I’m glad I didn’t upgrade my running systems yet because I’m sure this would break the serial ports.

Nevermind, I feel like a dummy. I didn’t see the new dietpiEnv.txt file in the /boot directory where as it used to be armbianENV.txt

I put in uart1 and uart2 in the overlays line and rebooted, Serial ports worked right away!