Enable Raspberry cam module

Hello all.

After getting a 3D printer, I decided to use Octoprint on a Pi4 (and also move VPN and PiHole from a VM on my Mac to the Pi).

All that said, DietPi, PiHole and VPN are running great.
However, I’m not able to get the camera working. I plugged the camera module in (V2.1) enabled the camera in Dietpi-config.

Now I want to add the camera to Octoprint, but it tells me that the camera is not found.

As I’m a newbie in Linux, I don’t know how to test if the camera is installed correctly or it is even working ok or I just too dumb to
configure it right in octoprint.

Someone out there to help me?
I found the command

hdparm -i /dev/video0

that will give me

 HDIO_DRIVE_CMD(identify) failed: Inappropriate ioctl for device
 HDIO_GET_IDENTITY failed: Inappropriate ioctl for device


can you have a look pls.

I did some additional Google search.
Is it possible that the needed drivers are not available for 64bit system?
I read something on the m-jpeg streamer site on GitHub.
And I’m also not able to install RPI Cam Control as it does not support 64bit system.

You could simply check it if you have a spare SD card

Finished setting up DietPi 32bit on another SD card.
After installing m-jpeg streamer I’m able to use the camera in octoprint or with the local snapshot address in my browser.
Tried the same again with the 64bit system but I can’t even reach the m-jpeg server. It doesn’t seem to start.

Probably still an issue on th Raspberry Pi OS 64bit Beta

Indeed the 64-bit version of the Raspberry Pi GPU libraries ships only a subset of what the 32-bit version ships. I’m not sure which part is required, has an input_raspicam.so actually been compiled? ls -l /opt/mjpg-streamer. The default UVC module seems to work as well: https://www.raspberrypi.org/forums/viewtopic.php?p=1699885#p1699885
But that user obviously was able to compile it on 64-bit :thinking:.