Emby server

Hi. I try to install Emby server from dietpi-software but i got error. What can i do?

Hi and thanks for your report.

Yeah indeed this happens since the latest Emby release is only available for Windows. We reworked the installer to use a last known fallback URL if the latest release does not contain one for Debian: https://github.com/MichaIng/DietPi/commit/ce890930d8239433f307b0bbe6219a84a718aedd

Please do the following:

sed -i 's#"$(curl -s "$INSTALL_URL_ADDRESS" | grep -m1 "browser_download_url.*emby-server-deb_.*_$arch\\.deb" | cut -d \\" -f 4)"#"https://github.com/MediaBrowser/Emby.Releases/releases/download/$arch.deb"#' /DietPi/dietpi/dietpi-software
/DietPi/dietpi/software install 41 # to rerun the Emby install

I had the same issue and tried your fix.
It started installing but failed at dpkg

[ SUB1 ] DietPi-Software > Installing Emby Server: web interface media streaming server
[ OK ] DietPi-Software | Connection test: https://api.github.com/repos/MediaBrowser/Emby.Releases/releases/latest
[ OK ] DietPi-Software | wget https://github.com/MediaBrowser/Emby.Releases/releases/download/ -O 41.deb
[FAILED] DietPi-Software | dpkg -i 41.deb
[ INFO ] DietPi-Software | Trying automated APT fix
[ INFO ] DietPi-Software | APT fix, please wait…
[ OK ] DietPi-Software | G_AGF
[ OK ] DietPi-Software | Cleaning download directory

But the APT fix afterwards succeeded. In some cases we choose this way if we install software with many/changing package dependencies:

  • Run DPKG install
  • Run into error because of missing dependencies
  • Run apt-get -f install to let APT automatically install missing dependencies.

Perhaps we should add some info that an error here is expected.

Or does your Emby finally not work?

I tried the following.

But still get dpkg error. In dietpi-software it shows that Emby is installed but I checked with htop, it is not running.

My bad. Sorry it did install correctly.
I was trying to access it from http://app.emby.media/#!/home.html not from the IP http://192.168..*:8096

After I set it up, it started the services.

Thanks for your help MichaIng

how to try this code

sed -i ‘s#"$(curl -s “$INSTALL_URL_ADDRESS” | grep -m1 “browser_download_url.emby-server-deb_.$arch\.deb" | cut -d \" -f 4)"#"https://github.com/MediaBrowser/Emby.Releases/releases/download/$arch.deb”#’ /DietPi/dietpi/dietpi-software
/DietPi/dietpi/software install 41 # to rerun the Emby install

Thank you for your interest. solved with manual installation.