Drive Manager dosent show up, but is detected running

Required Information

  • DietPi version: Did a update after having the issue, so its the system suggestet freshest release
  • Distro version: Command dosent work.
  • Kernel version: Linux DietPi 5.15.32-v8+ #1538 SMP PREEMPT Thu Mar 31 19:40:39 BST 2022 aarch64 GNU/Linux
  • SBC model: RPi 4 Model B
  • Power supply used: official power supply
  • SD card used: Runs on a SSD (found it in a list recommended for use with RPi)

Hope you can work with the informations above.

My problem: First thing to say… I just love DietPi! I´m a linux newbie and dietpi is just amazing. Its userfriendly and perfect for working with via SSH. It solved my problem migrating an NFTS drive to a RPi. This installation runs for like 2 month, very smooth, everything is working as intended. It just runs PlexMedia on it. So now I wanted to migrate a new NTFS drive to the RPi and this is actually the problem. I was connecting via SSH and found the system running as it should, but as I went to the launcher and was trying to load the drive manager a black window appeared. I closed the connection because I wasnt able to navigate back and tried again. A dialog appears telling me “Concurrent execution of DietPi-Drive_Manager detected”. So if dietpi detecting the drive manager to be launched in another session, it means it actually run, but dosent show up. So what happend to dietpi installation? I want to avoid reinstalling it.

Maybe you guys can help me.

(Sorry for my english, I´m not a native speaker)

Welcome to our community.

As you closed the SSH session, drive manager keeps running in the background. Our scripts are designed in a way to prevent concurrent sessions. Therefore you are blocked now. Basically you have 2 options. Kill the first session or reboot your system.

1 Like

Thats not the problem. Maybe I wrote it down a little bit confusing. I know what the message is trying to say. My problem begins way earlier as I said. When I first open the Drive Manager it just show a black terminal, nothing appears, it never load. But if I then close the session and open a new one, it says Drive Manager is already running. So my guess was, its running but it dosent show up… thats the problem I´ve got. I cant even see the drive manager, but if I try to open it in a new session, it says it is running.

Edit: Never mind! As I was writing, it just opened.

Does it mean drive manager is working now? Even after a reboot?