DPi6+Orange Pi Zero w/ ExpBoard: No soundcard detected

Hey guys!
I just upgraded from 159 to 6 on an OrangePi Zero w/ Expansion Board, and now it does not recognize the Sound Card anymore. I’m trying to get the sound from the 3.5mm jack.

Enabling the 3.5mm Sound Output in the dietpi-config, activating the EQ, and getting the ALSA Output Info:

 DietPi-Set_Hardware
─────────────────────────────────────────────────────
 Mode: soundcard (default-eq)

[  OK  ] soundcard default | Completed
cannot open mixer: No such file or directory

 DietPi-JustBoom
─────────────────────────────────────────────────────
 Mode: ALSA Output Info

cat: '/proc/asound/card*/pcm0p/sub0/hw_params': No such file or directory


[  OK  ] Completed, press any key to exit...

Press any key to exit...

Listing the soundcards and the uname the system:

root@DietPi:~# aplay -l
aplay: device_list:270: no soundcards found...
root@DietPi:~# uname -a
Linux DietPi 4.14.15-sunxi #28 SMP Mon Jan 29 07:24:48 CET 2018 armv7l GNU/Linux

The weird thing is that it does recognize the board (I tested with a USB drive plugged in and had no problems).

Any ideas?

So, I solved my own problem. It looks like this kernel might not have the required sound drivers, but the solution is simple enough!

To anyone with the same issue, you have to edit the /boot/armbianEnv.txt file and add overlays=analog-codec to the end of the file.

Hi, I have two of these boards and one expansion card but have never used it for sound - what do you use it for and what’s the quality like?

John

Hi John!

I bought the OPi0 to use mainly as a headless web server at home only to serve a personal static page (got tired of paying for hosting just for that)! Than I realized I could hook it up the stereo amplifier I use with my turntable and have Spotify stream directly to the receiver’s AUX port. I now use it as both the webserver AND the Spotify Connect client (with Spotify Premium).

It sounds absolutely amazing (again, Spotify Premium, so high quality 320 kbps streaming). I never found a sound quality comparison on the OPi0, but comparing the same album on vinyl (directly from the turntable) and the 320kbps streaming, I must say it does the job pretty well!

I’m not an audiophile by all means, so people with very high standards for their music could disagree… but for a little more than 20 USD you won’t be disappointed!

For reference, this is my audio setup. The OrangePi Zero is hidden in the back!

Alex

Thanks, nice retro setup :slight_smile:

John

hello
I´d like to revive my old OPIZ, Dietpi 6 starts well, wifi ok but when updating on first boot all fucked up (can’t reach repository) end of story.
I tried to change the repository with archive in dietpi.txt (I don’t really know what I’m doing) but no way
I just need to install alsa and sox , no need recent kernel or other software but wifi)
Any idea?
Thanks for help

Why do you use Dietpi 6?

Best would be to share error message from the first boot process. But use a fresh install and not the one you tried to fix

Hello
Thanks for your reply
@Jappe Orange pi zero is not supported anymore Dietpi 6 is the best you can find.
@Joulinar You’re right but as I said at the end of the first boot everything goes bad and it’s completely stuck, I don’t know how to save the logs.

I think I’m going to divert to Armbian old release as well which gave me this morning wifi and stablish console. I come back rapidly to you if/when I need your help.
Have a nice day

simple way would be to create screen prints or picture.