Docker Issue on Asus Tinker Board


After an “optimized software” docker installation, the dockerd daemon does not seem to be able to start correctly.
Here’s the underlying error I see (starting manually here but same output on docker.service):

  • DietPi v158

root@alfa:~# dockerd
INFO[2017-11-19T06:47:01.152989958+01:00] libcontainerd: new containerd process, pid: 5723
WARN[0000] containerd: low RLIMIT_NOFILE changing to max  current=1024 max=1048576
WARN[2017-11-19T06:47:02.229270000+01:00] devmapper: Usage of loopback devices is strongly discouraged for production use. Please use `--storage-opt dm.thinpooldev` or use `man dockerd` to refer to dm.thinpooldev section.
WARN[2017-11-19T06:47:02.298412792+01:00] devmapper: Base device already exists and has filesystem ext4 on it. User specified filesystem  will be ignored.
INFO[2017-11-19T06:47:02.399242251+01:00] [graphdriver] using prior storage driver: devicemapper
INFO[2017-11-19T06:47:02.411907292+01:00] Graph migration to content-addressability took 0.00 seconds
WARN[2017-11-19T06:47:02.412702084+01:00] Your kernel does not support cgroup memory limit
WARN[2017-11-19T06:47:02.412883209+01:00] Your kernel does not support cgroup rt period
WARN[2017-11-19T06:47:02.412969251+01:00] Your kernel does not support cgroup rt runtime
WARN[2017-11-19T06:47:02.413034001+01:00] Unable to find blkio cgroup in mounts
WARN[2017-11-19T06:47:02.413395959+01:00] mountpoint for pids not found
INFO[2017-11-19T06:47:02.414250542+01:00] Loading containers: start.
WARN[2017-11-19T06:47:02.419273042+01:00] Running modprobe bridge br_netfilter failed with message: modprobe: WARNING: Module br_netfilter not found in directory /lib/modules/4.4.16-00006-g4431f98-dirty
, error: exit status 1
INFO[2017-11-19T06:47:02.629120792+01:00] Default bridge (docker0) is assigned with an IP address Daemon option --bip can be used to set a preferred IP address
Error starting daemon: Error initializing network controller: Error creating default "bridge" network: Failed to Setup IP tables: Unable to enable NAT rule:  (iptables failed: iptables --wait -t nat -I POSTROUTING -s ! -o docker0 -j MASQUERADE: iptables: No chain/target/match by that name.
 (exit status 1))