Docker + Docker-compose

New to DietPi. Using a Rock64 with DietPi

Selected ONLY the following list of softwares:

  • [162] Docker
  • [xx0] openSSH
  • [xx3] MC
  • [x12] Iperft
  • [x17] Git Client

Did the config for the Rock64, localisation, network, mount some drives, and several reboots later, done.

Trying to install: docker-compose with no luck.

sudo curl -L`uname -s`-`uname -m` -o /usr/local/bin/docker-compose
sudo chmod +x /usr/local/bin/docker-compose

a simple:

docker-compose --version

leads to:

/usr/local/bin/docker-compose: line 1: Not: command not found

Can’t install Dockers as, well, docker-compose is not working. What gives?


Were you ever able to figure this out? I just recently started messing around with Docker and thinking about switching my current RPi 3 setup to using Docker. I’ll mess around with it tomorrow to see if I can get docker-compose to work. It would be nice if we could get Docker-Compose as a part of dietpi-software.


I don’t have a rock64 yet, am waiting for it to be delivered.

Regarding your issue, have you tried this…

# apt-get install -qy python-pip --no-install-recommends
# pip install pip --upgrade
# pip install docker-compose

In reply to my previous post. Trying to install via pip threw some errors and failed.

Instead do a “sudo apt install docker-compose” and it will install v18 of docker-compose. Just remember to specify services version 2 in your docker-compose.yml file rather than version 3 otherwise docker-compose will fail to bring up your services.

Hope this helps in some way.


that error

/usr/local/bin/docker-compose: line 1: Not: command not found

is because there is no armv7l in the official github repo and the file that is create has only “Not Found.” in it.

use this if you want a newer version

sudo curl -L "" -o /usr/local/bin/docker-compose

Can someone install it on rock64?

It worked for me!