Docker breaks after updating DietPi to latest version

Creating a bug report/issue

Required Information

  • DietPi version | cat /boot/dietpi/.version

G_LIVE_PATCH_STATUS[1]=‘not applicable’

  • Distro version | echo $G_DISTRO_NAME $G_RASPBIAN


  • Kernel version | uname -a

Linux DietPi-LocalServices 5.10.0-21-amd64 #1 SMP Debian 5.10.162-1 (2023-01-21) x86_64 GNU/Linux

  • SBC model | echo $G_HW_MODEL_NAME or (EG: RPi3)

Virtual Machine

Additional Information (if applicable)

  • Software title | Docker/Docker Compose
  • Was the software title installed freshly or updated/migrated? Updated/Migrated
  • Can this issue be replicated on a fresh installation of DietPi? N/A
    ← If you sent a “dietpi-bugreport”, please paste the ID here →
  • Bug report ID | echo $G_HW_UUID

Steps to reproduce

  1. DietPi-Update to latest version
  2. Run docker container ls

Following error message appears

Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?

Expected behaviour

  • It should be listing all my containers and docker should be running

Actual behaviour

  • Docker fails to start

Extra details

  • root@DietPi-LocalServices:~# systemctl status docker -l
    ● docker.service - Docker Application Container Engine
    Loaded: loaded (/lib/systemd/system/docker.service; disabled; vendor preset: enabled)
    Drop-In: /usr/lib/systemd/system/docker.service.d
    Active: failed (Result: exit-code) since Sun 2023-02-12 14:20:31 GMT; 1min 53s ago
    TriggeredBy: ● docker.socket
    Process: 11707 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=1/FAILURE)
    Main PID: 11707 (code=exited, status=1/FAILURE)
    CPU: 87ms

Tried updating Docker using the following command;

apt update
apt install docker-ce docker-ce-cli

And also tried to run: dietpi-software reinstall 134

Neither helped and docker does not work correctly.

Thanks for any and all help!

I guess you are hit by following bug of Docker software DietPi-Software | Docker: Service fails to start after upgrade (AppArmor) · Issue #6126 · MichaIng/DietPi · GitHub

1 Like

Did not see that, thank you. I’ll give it a try!

Check this video if it helps you.
[Fixed Dietpi update dropping containers - YouTube]

just to avoid a missunderstanding, this is NOT a DietPi issue. It’s a bug in Docker software directly.

Issue is describe on Docker release notes as known issue Docker Engine 23.0 release notes

Finally, Docker 23.0.2 has been released fixing the issue on x86 Docker Engine 23.0 release notes