Disable all HDD spin down?

Hi, I have two hard drive connected to my Raspberry Pi 3. One is SATA III, one is IDE, all with relative HDD box via USB.

This is the situation:

root@DietPi:~# hdparm -C /dev/sda

/dev/sda:
 drive state is:  unknown
root@DietPi:~# hdparm -C /dev/sdb

/dev/sdb:
 drive state is:  standby
root@DietPi:~#

/dev/sda ==> IDE drive
/dev/sdb ==> SATA drive

What I have to do to disable ALL spin down?

Thank you! :smiley:

IDE look unsupported
SATA looks fine


You’ll need to edit /etc/hdparm.conf, and configure section /dev/sda:

#DietPi external USB drive. Power management settings.
/dev/sda {

        spindown_time = 0 # = disabled
        apm = 254

}

Also add one for sdb

Hi, for /dev/sda (IDE disk) that lines already exists in hdparm.conf .
I created that lines for /dev/sdb (SATA disk) but the results is:

root@DietPi:~# hdparm -C /dev/sdb

/dev/sdb:
 drive state is:  standby

Is that ok?
Thank you!

That disk continuous to spin down. Sometimes I found it unmounted(only SATA drive: /dev/sdb) :roll_eyes:

Its possible the drive has its own power management, and, HDParam does struggle with some USB > SATA converters which are not compliant (especially china town).

Check the available supported features available to HDparm:
http://www.linux-magazine.com/Online/Features/Tune-Your-Hard-Disk-with-hdparm