Dietpi with Rapsberry pi 3

I’m a new user of dietpi (2-3 weeks) with a raspberry pi 2. I’m very pleased so far with this distribution!

I tried yesterday to boot my new raspberry pi 3 with the same SD card: no luck. The green led goes blinking (4 long bips, 4 short bips, 1 seconde pause and so on…). I tried with a fresh install of dietpi on another SD card, same problem.

It doesn’t come from the pi: I tried with a fresh install of raspbian lite, and it’s working well!

Any idea what I can try?

Hi shlagwu,

The same image one the same SD Card, as you used in RPi2? Which version? Jessie or Wheezy?

For RPiv3 where is a new image (only Jessie - 2016-03-03 13:15 119M ):
Have you tried this?


first try: same image on the same SD card (Jessie)
uname -a: Linux DietPi 4.1.14-v7+ #4 SMP PREEMPT Fri Dec 11 14:48:01 EST 2015 armv7l GNU/Linux

second try: freshly burnt Jessie on another SD card. Same problem (green led blinking 8 times)

Hi shlagwu,

I believe this indicates the RPi3 firmware/boot loader is missing from /boot. This would suggest you are writing the older DietPi image.

Please make sure you are using the updated image. Use this direct link to download the image, then write again to SD:

If problems persist with the updated image, please let me know.

Well… i had two folders: DietPi_RPi-(Jessie) (1) and DietPi_RPi-(Jessie). Guess wich one I used ? :roll_eyes:

Working great now, thanks for the help! :wink:

Hehe, trust me, i’ve done the same thing myself many many many many… times :rofl: