Dietpi will Be Great Choice For Surface RT Your Helpe Is Needed

I DON’T really needs GUI-integrated tools if i can solve the

│ WiFi : Not Found | [On] | Disconnected │

with out the need for network-manager

Then you can switch onboard WiFi on via dietpi-config and end users can then use it to actually scan and enter WiFi credentials for their SSID.

i’m thankful for your help the problem is that no matter what i do dietpi-config is not showing that found device and or being capable to scan for network when i do scan it splash screen and go back to adaptter settings and even i put wi-fi setup byhand it keeps showing │ WiFi : Not Found | [On] | Disconnected │

Did you reboot the system once onboard WiFi has been activated? Can you share ip a after a reboot happen?

yes ser
and finally i could capture the screen when i do wifi scan

pls can you share following

ip a


what is the name of the adaptor number 5?

the adaptor number 5 ( mlan0 ) i think this is why it’s not working it should be

it’s the driver
Ok this read me might have answer
But how to make it work within the first time setup

Did you enable the internal wifi in the network adapter menu (below the ethernet and wifi settings) in dietpi-config and reboot the system. I had the same issue some days ago.

in Surface RT i dont have the third line in the adapter options at all
(Onboard wifi )

The option is shown on RPI boards only, if I’m not mistaken.

I guess you need to add/activate the driver before creating an image

At least our script explicitly expect a WiFi adaptor called wlan0.

Hmm, mlan seems to be a different adapter type, but I couldn’t nail it down. I’ll give you an interfaces config when I’m home to try bringing it up that way instead of via dietpi-config.

Does this exist?

ls -l /sys/class/net/mlan0/wireless

Try the following:

cat << '_EOF_' > /etc/network/interfaces.d/mlan0.conf
allow-hotplug mlan0
iface mlan0 inet dhcp
wireless-power off
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
sed -i '/local wifi_iface=/c\local wifi_iface=mlan0' /boot/dietpi/func/dietpi-wifidb
dietpi-wifidb # try to scan for SSIDs and configure one
ifup mlan0

thank you
i will inform you with results as soon i do it . im on trip today i can’t work on the device

Wawee yes MichaIng

thank you you did it

it has connected to wifi yes

1 Like

Oky now we can move to the next stage.

can we make this 2 orders to start using

cp -r kernel-modules/lib/* /lib/
cp -r /boot/mlan0.conf/ /etc/network/interfaces.d/


Jep, this will work. Don’t forget to add a shebang:

cp -r /path/to/kernel-modules/lib/. /lib/
cp /path/to/mlan0.conf /etc/network/interfaces.d/

Adjust /path/to with the location where you store those files… If they are on a dedicated drive, it needs to be mounted first. If it’s not on a dedicated drive, of course you could place them to the right directory in the first place :wink:.

:roll_eyes: how to
you know it should run as root user to edit root volumes