Dietpi-update problem with timesync

Creating a bug report/issue

I have searched the existing open and closed issues

Details:

  • Date | Tue Feb 20 10:36:53 CET 2024
  • DietPi version | v9.1.1 (MichaIng/master)
  • Image creator |
  • Pre-image |
  • Hardware | RPi 4 Model B (aarch64) (ID=4)
  • Kernel version | Linux bookworm 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr 3 17:24:16 BST 2023 aarch64 GNU/Linux
  • Distro | bookworm (ID=7,RASPBIAN=0)
  • Command | systemctl start systemd-timesyncd
  • Exit code | 5
  • Software title | DietPi-TimeSync

Steps to reproduce:

  1. call “dietpi-update”

Expected behaviour:

  • update should run without any issues

Actual behaviour:

Extra details:

  • …

Additional logs:

Failed to start systemd-timesyncd.service: Unit systemd-timesyncd.service not found.

IDK why this happened and why he service is missing on your system, but to circumvent the issue you can select Change command and just type true and hit return, it should continue then without the time sync check. But if your system time is out of sync this could lead to new problems, so I recommend to make a backup before you try that.

did you upgrade from Debian Bullseye to Debian Bookworm recently?

Maybe this fits NTP wont sync, fails to find systemd-timesyncd.service - #2 by Joulinar

1 Like

In the meantime I switched to timesync method 0 / Custom and tried again - and it seemed to work.

The try to install systemd-timesyncd via apt-get didn’t work, it told me “packet not found”. :thinking:

Yes, I did - but I therefore used the new image :wink:

As I said - reinstall of systemd-timesyncd didn’t work…

Can you share the whole output of package installation?

apt update
apt -y install systemd-timesyncd

Hi Joulinar,

yes, this time it worked. I think, as I switched to timesync mode “custom”, the dietpi update was running through without an issue, it solved the problem with reinstallation of systemd-timesyncd.

I’m not sure, but maybe at some point I was playing around with NTP / SNTP and installed the ntp package that (maybe?) deactivated systemd-timesyncd.

But thanks for your help!

Yes because we don’t trigger the time sync anymore. But this would require another time synchronisation service, otherwise your system will run out of time sync. Because our service has been disabled now.

Yes - must have been ntpd. I restored a backup where ntpd was running… think, I forgot… :face_with_monocle: