DietPi update failed - Raspberry Pi 4

Got notified in console that newer version exist so I tried to update DietPi on my Raspberry Pi 4 SBC but it failed.

Seems it tried to execute command: “apt-get -y -eany update” but it failed to do so.

I created bug report file - reference: 8e8446a7-feba-4fdb-9672-1145f73a2074

This is what console outputted when I halted update procedure:


  • Date | Tue May 2 20:05:17 CEST 2023
  • Bug report | 8e8446a7-feba-4fdb-9672-1145f73a2074
  • DietPi version | v8.16.2 (MichaIng/beta)
  • Image creator |
  • Pre-image |
  • Hardware | RPi 4 Model B (aarch64) (ID=4)
  • Kernel version | Linux KAR01SRV01 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr 3 17:24:16 BST 2023 aarch64 GNU/Linux
  • Distro | bullseye (ID=6,RASPBIAN=0)
  • Command | apt-get -y -eany update
  • Exit code | 100
  • Software title | DietPi-Update

Steps to reproduce:

Expected behaviour:

Actual behaviour:

Extra details:

Additional logs:

Ign:1 xenial/mongodb-org/3.6 InRelease
Hit:2 bullseye InRelease
Get:3 bullseye-updates InRelease [44.1 kB]
Hit:4 xenial/mongodb-org/3.6 Release
Ign:5 stretch InRelease
Get:6 bullseye-security InRelease [48.4 kB]
Err:7 stretch Release
  404  Not Found [IP: 80]
Get:8 bullseye-backports InRelease [49.0 kB]
Get:9 bullseye InRelease [23.6 kB]
Hit:10 bullseye InRelease
Get:12 bullseye-security/main arm64 Packages [233 kB]
Get:13 bullseye/main arm64 Packages [308 kB]
Reading package lists...
E: The repository ' stretch Release' no longer has a Release file.

Have a look at following Err:8 stretch Release │ │ 404 Not Found [IP: 80] - #10 by Joulinar


Seems whoever uses UniFi Easy Install Script from Glenn R. from Ubiquiti could expect this issue to happen.

I fixed it simply by removing “glennr-install-script.list” from “/etc/apt/sources.list.d”

Thanks @Joulinar for pointing me in the right direction. Cheers!

Wasn’t it an option to adjust source list to Bullseye?

As far as I know, UniFi Network Application depends on specific mongodb release and there is always something specific that needs to be done so it could work properly. This “glennr-install-script.list” was added by the script itself (not sure why) and as I have no intention to update UNA to the newer version in foreseeable future because of it lately being more broken than fixed with each new release, I decided to remove it from the system.

to bad that UniFi is not providing a software that is able to run on current ARM based system.

I have switched to the docker version of Unifi to avoid all this dependencies nonsense. Combine it with portainer from the dietpi package list to get some peace of mind.

1 Like