dietpi-update/apt-get update Error

at the moment I’m using v6.21.1 on my Odroid XU4.
I wanted to update my System to v6.22.3 by using dietpi-update but it failed. When using apt-get update I get the same error.
I already tried to change the APT Mirror (dietpi-config → Network Options_ Misc → APT Mirror) but the error is the same.
Does anybody know what to do?
Thanks in advance!

root@DietPi:~# apt-get update
Ign > > jessie InRelease
Hit > > all InRelease
Get:1 > > jessie-updates InRelease [7,340 B]
Ign > > jessie-backports InRelease
Hit > > jessie InRelease
Hit > > jessie Release.gpg
Ign > > jessie-backports Release.gpg
Get:2 > > jessie/updates InRelease [44.9 kB]
Hit > > jessie Release
Ign > > jessie-backports Release
Hit > > all/xu3 armhf Packages
Hit > > all/main armhf Packages
Hit > > all/testing armhf Packages
Hit > > jessie/main armhf Packages
Get:3 > > jessie/updates/main armhf Packages [637 kB]
Hit > > jessie/backports armhf Packages
Get:4 > > jessie/main armhf Packages [6,675 kB]
Get:5 > > jessie/contrib armhf Packages [37.8 kB]
Get:6 > > jessie/non-free armhf Packages [62.5 kB]
Get:7 > > jessie/contrib Translation-en [38.3 kB]
Get:8 > > jessie/main Translation-en [4,581 kB]
Ign > > all/main Translation-en_GB
Get:9 > > jessie/non-free Translation-en [72.0 kB]
Ign > > all/main Translation-en
Ign > > all/testing Translation-en_GB
Get:10 > > jessie/updates/non-free armhf Packages [4,243 B]
Ign > > all/testing Translation-en
Ign > > all/xu3 Translation-en_GB
Ign > > all/xu3 Translation-en
Get:11 > > jessie/updates/main Translation-en [335 kB]
Hit > > jessie/updates/contrib armhf Packages
Hit > > jessie/updates/contrib Translation-en
Get:12 > > jessie/updates/non-free Translation-en [11.8 kB]
Ign > > jessie/backports Translation-en_GB
Ign > > jessie/backports Translation-en
Ign > > jessie/main Translation-en_GB
Ign > > jessie/main Translation-en
Err > > jessie-backports/main armhf Packages
404 Not Found
Err > > jessie-backports/contrib armhf Packages
404 Not Found
Err > > jessie-backports/non-free armhf Packages
404 Not Found
Ign > > jessie-backports/contrib Translation-en_GB
Ign > > jessie-backports/contrib Translation-en
Ign > > jessie-backports/main Translation-en_GB
Ign > > jessie-backports/main Translation-en
Ign > > jessie-backports/non-free Translation-en_GB
Ign > > jessie-backports/non-free Translation-en
Fetched 52.3 kB in 20s (2,546 B/s)
W: Failed to fetch > > Unable to find expected entry ‘main/binary-armhf/Packages’ in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch > > 404 Not Found

W: Failed to fetch > > 404 Not Found

W: Failed to fetch > > 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

Jep this is a known issue since Debian dropped backports and update branches for Jessie systems from their repository.

Please edit /etc/apt/sources.list and remove the jessie-backports and jessie-updates lines.

We will patch this as well with v6.23 update prior to APT is called.

Thank you verry much! This solved the problem

This also affects the Odroid C1 build, which is only available for Jessie AFAICT.

I wiped the unit and wanted to start afresh, but I can’t get through the initial setup anymore.

It would be nice if you could update the C1 image as well - or is there a way to sidestep this when going through the initial setup? From what I can tell, you can’t drop to the shell and adjust apt sources before apt update gets run.


thats the exact problem i am having at the moment, fresh install for oDroid C1, fails to update
i am currently stuck with

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
sh: 1: /usr/bin/xauth: not found
[  OK  ] Root access verified.
 DietPi     | Update available
 v#!/bin/bash.G_DIETPI_VERSION_CORE=6       | Odroid C1 (armv7l)
 IP eth0    |

if i burn a C1 image to the eMMC, download and run the VMWare image of dietpi, mount the eMMC into the dietpi OS running in VMWare, could i edit the /etc/apt/sources.list that way?

Jep that is possible. Meanwhile we have an Odroid C1 Stretch image. Sadly Stretch only works with the mainline kernel that lacks video features, thus no screen will work, only SSH and serial console access.

When running into the issue with the Jessie image on first boot, you can skip/break the setup to go into console, then remove the APT sources list lines as mentioned above. Then run: /DietPi/dietpi/login to re-run the first run update and setup steps.