Dietpi-software: not found

Hi all,

today I tried to install DietPi (following the tutorial from the DietPi website) on my Raspberry Pi 2 v1.1 and I am getting stuck at the point where I login via SSH and supposed to accept the GPL-License. Instead I see what you can see in the attached screenshot. I can’t even use the dietpi-software command

I had installed in the past DietPi on another of my Pis and worked without any issues. What am I doing wrong here? I tried 3x times to flash the image again and again on my SD card with the same result.

Perhaps no help to you but I have exactly the same problem attempting to install for a Raspberry pi B+.

Yeah there is a bug introduced with last update?!

workaround: usermod -d /root -s /bin/bash root


This is not related to the update directly. There was an issue on our script building the image. But these faulty images should never been populated. I will contact @MichaIng to create new image and remove the faulty one. Sorry for inconvenience

1 Like

You need to reboot for that to work as well!
Didn’t make any difference for me otherwise. Thanks for the leg up though I’ve been pulling my hair out all day trying to troubleshoot this.

A new login into CLI should have been sufficient.

I can confirm. But maybe @Jappe can add this this his post :slight_smile:

I added the workaround as solution over there.

Guys, did you download a ready to use image or did you tried to create an own install using the installer script? And if you used an image, was it the ARMv6 one? Because this is the only one that got updated on the last days. Rest of images has been created before the installer got buggy.

Yes, downloaded the ARMv6 image, this one to be precise

ok we updated the ARMv6 image in meantime. Should work normal again.