dietpi-software gets stuck

Hello,

I have problems with installing software with dietpi-software.
The Installer gets stuck at different points.(depends on software).

For example I just now tried installing deluge.

DietPi-Software
─────────────────────────────────────────────────────
Mode: Configuring Deluge: bittorrent server with web interface (python)

[ OK ] DietPi-Software | Connection test: https://raw.githubusercontent.com/Fo urdee/DietPi/master/.conf/dps_45/deluge.conf
[ OK ] DietPi-Software | wget https://raw.githubusercontent.com/Fourdee/DietPi /master/.conf/dps_45/deluge.conf -O 45.deluge.conf
[ OK ] DietPi-Software | cp -f 45.deluge.conf /mnt/dietpi_userdata/deluge/.con fig/deluge/core.conf
[ OK ] DietPi-Software | Cleaning download directory
[ OK ] DietPi-Software | Connection test: https://raw.githubusercontent.com/Fo urdee/DietPi/master/.conf/dps_45/deluge_web.conf
[ OK ] DietPi-Software | wget https://raw.githubusercontent.com/Fourdee/DietPi /master/.conf/dps_45/deluge_web.conf -O 45.deluge_web.conf
[ OK ] DietPi-Software | cp -f 45.deluge_web.conf /mnt/dietpi_userdata/deluge/ .config/deluge/web.conf
[ OK ] DietPi-Software | Cleaning download directory
[ OK ] DietPi-Software | Setting in /etc/default/deluged adjusted: ENABLE_DELUGED=1




And this is how far it goes. I already waited 30min.

The same happened with transmission and sonarr. They also got stuck at writing something in the config. After a while I aborted the installation but the software works. It doesn’t show up as installed in dietpi-software though.

Update: I tried installing deluge again and I just left it for around 2 hours.When I came back it was finished.

Which device are you running DietPi on?

I just checked the following install steps:

Jep that must be it. The output from setting permissions is hidden. If you have lots of files in your dietpi_userdata this can take a lot of time without any output. I am also not very happy with this, e.g. having Terabytes of cloud data there, getting chown/chmod again on every software install.

You can verify that it is indeed what takes so long:
/DietPi/dietpi/func/dietpi-software setpermissions
This will produce some output that is hidden during software install, so you should be able to see progress there.
You can safely interrupt the script to now wait for 2h again :wink:.

I think we need to optimize that function a bid, at least produce output (inform about things can take a while) and processing animation, so users know the machine is still working and not crashed.

screen is also a nice option

Start screen, start an application, detatch from screen, logout SSH terminal and the application in screen will keep going

https://www.rackaid.com/blog/linux-screen-tutorial-and-how-to/