Dietpi Services not starting


recently I noticed that sometimes after booting my Raspberry not all of the Dietpi Services are starting, I assume it’s all the postboot services, see this screenshot:

At first I felt this only happens if I login via ssh directly after reboot, but this seems not to be the cause.
I already tried to find a hint by looking at the journalctl output and other log files, but could not find an error. Any ideas, where to search?

I digged into the journal messages and compared a successful with an unsuccessful boot. Seems the problem is somehow related to Systemd and/or Plymouth.

I can see that plymouth-quit-wait.service is started, because it says:

Starting Hold until boot process finishes up...

but plymouth-quit.service, which also should be started, is not. There is no

Starting Terminate Plymouth Boot Screen...

as in the successful start’s journal.

So it waits for plymouth to finish, without asking it to stop. Thus, target Multi-User System is not reached, and dietpi-postboot is not started. I have no access to a system to test right now, but will check if a manual start/restart of plymouth-quit.service forces to other services to follow.

I found a couple of similar problems when googling it, but no good explanation or solution so far. So still, any hint would be appreciated :slight_smile:

Can you please try to edit /etc/systemd/system/dietpi-postboot.service and remove from the After= line?
Then systemctl daemon-reload an check on next reboot.

This worked for me, thanks!

Okay, glad to here. This is already patched for DietPi v6.22 as well.

In the last few days every boot went fine, and I was wondering how that happened… I had switched to the dev branch in the meantime, with the already updated dietpi-postboot.service :smiley:
So obviously no more problems now, thanks!

Okay, just keep in mind that the dev branch indeed is under development and not tested throughout. But current stage at least does not contain some unfinished things, should work fine.