DietPi + RPi 4 + HyperPixel 4


Just tried out DietPi, runs great (decreased my boot times by 3 x)!

However, I’m trying to get the HyperPixel 4 (touchscreen LCD) running, and I am failing to achieve that. Installation on regular Raspbian was dead easy by just running the provided installation script.

The installation script is here:

I immediately noticed that editing /boot/config.txt does nothing as we need to edit /DietPi/config.txt instead. I have rectified that, but still not working. I am assuming some of the other assumptions that the script makes of where certain things should be is wrong. Could someone please help me out (essentially by pointing out what the script is doing wrong and fixing it or at least pointing me in the right direction)?

The other thing I noticed is that the init script requires the python library RPi, which is not installed by default. This is easy to rectify.

Delving a little deeper I noticed that the hyperpixel-rotate utility expects the existence of the following files:

which don’t seem to exist in the filesystem. The UDEV_FILE seems to be generated by the rotate utility, so it makes sense it’s not there since the service etc. seems to not be running.

Any help would be very much appreciated!



just some generell thinks:

Yes indeed config.txt needs to be maintained within /DietPi/ . Reason is that it is located on RamDisk. During reboot, this file will be written down to disk /boot/ . So it will overwrite original /boot/config.txt :slight_smile: Anyway this will change with next release v6.29 :wink:

python can be simply installed by using diepi-software. Reason for python not being available is, that DietPi is an extrem lean version of Raspbian Lite for Raspberry SBC’s. Means quite a lot of packages purged if they are not needed for basic functions :wink:

Regarding the /usr/share/ it seems something that is generated by xrandr Screen Configuration tool. But I’m not 100% sure honest to be.


So after some tinkering, I got it to work.

Fixing the location of the config.txt file + installing the RPi.GPIO library for python (I had python installed previously) + adding dtoverlay=vc4-fkms-v3d to the config.txt manually solved any issues that there may have been.

Thanks for the help, hopefully this will be helpful to someone else down the line.


just for clarification:

what do you mean by > Fixing the location of the config.txt ??

yep indeed dtoverlay=vc4-fkms-v3d is needed for RPi4 graphics. But could have been activated using dietpi-config