DietPi Rock64 - Clean install, no sound

Creating a bug report/issue

Required Information

  • Distro version | bullseye
  • Kernel version | Linux DietPi 5.15.80-rockchip64 #22.11.1 SMP PREEMPT Wed Nov 30 11:12:47 UTC 2022 aarch64 GNU/Linux
  • SBC model | ROCK64 (aarch64)
  • Power supply used | Default barrel one that was sold in the store.
  • SD card used | 64 gb microsd class1

Additional Information (if applicable)

  • Software title | N/A (Well, technically alsamixer)
  • Can this issue be replicated on a fresh installation of DietPi? Yes.

Steps to reproduce

  1. Install the image to the sd card.
  2. FInish setup in the device. Select the sound device in dietpi-config.
  3. Never any sound. There is not even sound systray icon.

Expected behaviour


Actual behaviour

No sound.

Extra details

AlsaMixer reports that neither HDMI or JackAnalog have β€˜any controls’.
Everything is well and nice, os updated and upgraded. alsamixer installed properly.

Update: PulseAudio was installed and it never loads. It is stuck in β€˜Establishing connection to pulseaudio, please wait…’

 Mode: ALSA Output Info


[  OK  ] DietPi-JustBoom | Completed, press any key to exit...

Probably something @MichaIng could help with.

1 Like

Does the sound card show up in

aplay -l


**** List of PLAYBACK Hardware Devices ****
card 0: Analog [Analog], device 0: ff010000.i2s-rk3328-hifi ff410000.codec-0 [ff010000.i2s-rk3328-hifi ff410000.codec-0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDMI], device 0: ff000000.i2s-i2s-hifi i2s-hifi-0 [ff000000.i2s-i2s-hifi i2s-hifi-0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Okay but they have no controls?

amixer -c 0 scontents
amixer -c 1 scontents

Seems to be a kernel issue then, wrong/incompatible driver.

These do not output anything in the terminal. I thought so that it was a driver error, sadly my linux knowledge is really basic. Is there a way to implement the audio driver without having to massacre the current installation?

Does it work with either edge or legacy kernel?

apt install linux-image-edge-rockchip64 linux-dtb-edge-rockchip64 linux-u-boot-rock64-edge
. /usr/lib/u-boot/
write_uboot_platform "$DIR" "$(lsblk -npo PKNAME "$G_ROOTFS_DEV")"

Applied these commands as instructed.
Rebooted, but nothing has changed. There is still no sound, ALSA reports no controls, cannot add volume plugin to traybay, and no volume software opens up.

Okay, last attempt then is the legacy kernel:

apt install linux-image-legacy-rockchip64 linux-dtb-legacy-rockchip64 linux-u-boot-rock64-legacy
. /usr/lib/u-boot/
write_uboot_platform "$DIR" "$(lsblk -npo PKNAME "$G_ROOTFS_DEV")"

This has been solved with the legacy kernel. Alsa reports now:


There’s sound now in my monitor speakers. Although, it still says there are no controls, so, no volume control as a caveat, but much better than no sound at all. Thank you!

Okay so far so good. You can then purge the other ones:

G_AGP linux-image-current-rockchip64 linux-dtb-current-rockchip64 linux-u-boot-rock64-current linux-image-edge-rockchip64 linux-dtb-edge-rockchip64 linux-u-boot-rock64-edge

Probably this is the reason why it does not work with recent kernel: this mornings updarte killed hdmi - ROCK64 - Armbian Community Forums
Although the error refers to HDMI and HDMI audio only.

1 Like