DietPi RetroPie install

Hi,
I have been trying to install RetroPie over DietPi, which is Raspbian based, and is even listed on this site as a link. I figured I would ask both forums and see what turns up since I tried searching for the issue on both RetroPie’s site and here. I am using a clean, fresh install of DietPi with no extra software installed and no desktop installed. I just have the terminal. The DietPi install went smoothly, and I followed the GitHub instructions like I always do to install RetroPie. The setup script ran and installed all packages for RetroPie as expected. However, on reboot, emulationstation failed to launch both from autostart and using the command “emulationstation”. I keep getting the error:

lvl10: Error initializing SDL!

lvl10: Renderer failed to initialize!
lvl10: Window failed to initialize!

Any ideas? Thanks!!!

Hi,

Might be missing the SDL library, try:

apt-get install libsdl2-2.0-0 libsdl1.2debian

Failing that, let me know and I’ll try a installation on a test system to debug.

Thanks, I’ll give it a try when I get home. The retropie forum mentioned something about recompiling SDL but couldn’t explain how. Someone from the team said it was not possible though. We shall see! :slight_smile:

Hmmm, just tried a fresh install of Diet Pi. I didn’t add any other software with my Diet Pi install. Should I? Installed SDL as you suggested, and installed RetroPie (per their GitHub instructions as always). The installs all went to plan, but I reached the same error. (In my last post, I meant a member of the RetroPie team, not yours.)

The standard RetroPie installation should work fine on DietPi: https://github.com/RetroPie/RetroPie-Setup#general-usage.

Not sure if their script installs build-essentials, but just in case, probably best to install this before starting:

apt-get install build-essential

Which RPi model are you running?

I am seeing this same issue when I tried installing on my system.

Using rpi3 with the latest (137) version of DietPi

Sorry for digging this up but did any of you had any luck?

Hi,

I’ll take a look and see what packages (if any) are missing from the RetroPie docs (as it only targets official Raspbian). As DietPi is extremely minimal, I believe that may be the issue, but will let you know:
https://github.com/Fourdee/DietPi/issues/707

Hi all,

Test installation works fine, unable to replicate.

If you are experiencing an issue with installing RetroPie, please follow my installation steps below, and let us know results: https://github.com/Fourdee/DietPi/issues/707#issuecomment-272184823

Hi!
You failed to replicate issue because you don’t tag any emulators to install. Retropie basic installation works fine, that problem exist for emulators. For example GemRB is looking for libsdl1.2.15-11 and can’t find it. Only available version for Dietpi seems to be libsdl1.2.15-10 debian armhf.

Maybe have a script to build SDL 2 in the next release

https://solarianprogrammer.com/2015/01/22/raspberry-pi-raspbian-getting-started-sdl-2/