Dietpi radxa zero package upgrade error

Required Information

  • DietPi version | 9.9.1
  • Distro version | ???
  • Kernel version | ???
  • Architecture | 3
  • SBC model | Radxa Zero
  • Power supply used | (5V 1A)
  • SD card used | (EG: SanDisk ultra)
  • Github: error report reference #: 18ae3db6-a154-4870-929b-dc2fa74729eb

Additional Information (if applicable)

  • Software title | NA
  • Was the software title installed freshly or updated/migrated? FRESH INSTALL
  • Can this issue be replicated on a fresh installation of DietPi? YES - tried twice
    ← If you sent a “dietpi-bugreport”, please paste the ID here →
  • Bug report ID | 18ae3db6-a154-4870-929b-dc2fa74729eb

Steps to reproduce

  1. First time boot up
  2. Automatically searches online for the distro upgrades

Expected behaviour

  • Distro package upgrades and installs
  • Normal 1st time load behaviour

Actual behaviour

  • See attached uploaded file for full text of error
    (I couldn’t seem to post the topic with all the links in it)

---------------------------------------------------------END
Please help a total noob to this all.

Thanks, :pray:
Dietpi package upgrade error.txt (2.4 KB)

looks like an issue with Armbian package server, you could wait for some hours and try again. Unfortunately, from our side we don’t have any influence in these servers as they are out of our control.

I’ve waited and waited and tried every few hours. Still, the same error occurs.

So? No solution. I’ll be installing a different OS then I guess.

Thanks all the same. I appreciate your reply.

from our side we can’t do anything as these servers are out of our scope/control. For testing you could use plain Armibian image to check if it behaves different.

You could try to disable IPv6 to check if this change something. Furthermore, check if there is any network component or security gateway that could influence the download.

Thanks again @Joulinar.

Upon doing the flashing of the image again, I noticed that the “source and destination checksums do not match”.

Perhaps this is the problem (or part of)?

Also, the image archive cannot be downloaded from the dietpi website anymore - it comes up with an error as well.

So I used the “failed” re-flashed image and this time dietpi installed with a ping error.

I ran the last action again and reconnected to wifi, and it did its updates and installing.

Everything seems to be installed now.