DietPi Plex - Not Authorized

I just set up Dietpi on my Raspberry pi 3 B and I wanted to set up Plex. But, when I try to open :32400/web, I got an error: “Not Authorized. You do not have access to this server”.

What I have done so far:

I know that many users have this problem, but some of them mentioned that it works for a while, but I cant get Plex running even from fresh install. Maybe someone has any tips on what I could do next?

In every tutorial, everybody, after install, just goes to ‘IP:32400/web’, logs in and everything works.
For example, other programms (Transmission, LXDE) works just like that.

I tried Jellyfin, but it is very slow, so I wanted to try something else

you installed plex using dietpi-sofware? Or manually? Can you share some more information on your system


  • DietPi version | cat /boot/dietpi/.version
  • Distro version | echo $G_DISTRO_NAME $G_RASPBIAN
  • Kernel version | uname -a
  • SBC model | echo $G_HW_MODEL_NAME or (EG: RPi3)
  • Power supply used | (EG: 5V 1A RAVpower)
  • SDcard used | (EG: SanDisk ultra)

Hm is tested on my RPi 4 and 3b+. Works without problems.
Did you used a selfhostes plex server it in the past? Maybe you have to remove your old server from you account?

Yes, I have installed Plex from dietpi-software.

  • DietPi version

  • Distro version
    bullseye 0

  • Kernel version
    Linux DietPi 5.15.76-v8+ #1597 SMP PREEMPT Fri Nov 4 12:16:41 GMT 2022 aarch64 GNU/Linux

  • SBC model
    RPi 3 Model B (aarch64)

  • Powersuply: 5V 1A

  • SD card: Kingston 32 GB

I haven`t used Plex before. And in my Plex profile there is no servers added. What I gave tried is to login with two different methods, two different emails (google, email), maybe that login saves somewhere?
Other services didn’t ask for email registrations (Jellyfin, Transmission, LXDE)

Well, Plex is not like other apps. There you need to have an account created at plex web site to be able to login

Yes, I have done that with two different emails.
One thing I haven’t tried - fresh DIetPi install…

Hey, @Joulinar !
Just did a fresh Dietpi install, first thing I did was install Plex. I open IP:32400/web, try to sign in (I have 2 registered accounts in Plex - one email, one Google).
Still, when I try to get in, I got a Not Authorized message. :frowning:
Maybe you have something in mind that I could try (anything else that I haven’t I mentioned)

You could try what is described in this post



Open Claim | Plex from your PC browser. You will get a Claim Code from Plex associated with your Plex account. This code is valid for 5 minutes
SSH into your Pi, run: curl -X POST
It will be something like

curl -X POST
  1. The claim process could take 10-20 seconds. Once done, you will get output like: ‘<MyPlex authToken=“xxxxxxxxxxxxx” username=“xxxxxxxxxxxxx” mappingState=“mapped”…’

@Jappe Thanks for the suggestion, I did this and I got the response, but I still can’t get in from IP:32400/web, same Not Authorized error. What I found in my Plex account, that finally I got my server showing up under Authorized devices:

So it’s blocking your access from another LAN IP.
In your data directory is a config file where you can set allowed networks which will need no auth.

Before under Preferences.xml, I didn’t have anything about my login info, now I checked and there is my login info (maybe from that “claim” task?!). I switched my Raspberry Pi to Wifi and thought, let’s try again and it works. :partying_face:

I hope that everything will still work after IP change, but so far so good.

1 Like