Dietpi on Odroid n2+ and no boot with USB disk attached

Hi,

I use from 1 year dietpi (now with 8.22.3 version) on my Odroid n2+ (unattended server) without any problem: until now I only used eMMC card (32GB) but recently I buyed a DAS module (Sabrent DS-SC5B) and I attached it to Odroid via USB 3.0 (actually with only 1 SATA disk).

I mounted this disk with dietpi-drive_manager and works perfectly: but when I reboot (with USB cable attached to Odroid) Dietpi doesn’t boot.

If I disconnect USB cable, dietpi boot as usual.

Can you help me?

Thanks

I reply to myself.

I connected a monitor and keyboard to ODroid N2+ to see what happened during the boot.

If I boot with USB drive connected, I don’t see anything on the monitor, total black screen: in this state, if I disconnect USB cable (without reboot) N2+ starts normally (with Dietpi from eMMC).

Anyone have any idea?

Thanks

So it even doesn’t try to boot until it’s disconncted sounds like a hardware issue to me? Or a power issue. But the Sabrent DS-SC5B has it’s own power brick. :thinking:
Do you use a metal case for the N2 by any chance?

Yes, Sabrent unit has power brick and I dont’use any case for N2+: but if was a power issue, why only during boot?

If I connect Sabrent unit after boot, I can mount all my 5 HDs from Odroid N2+.

I tried also to change N2+ switch boot (from MMC to SPI) and N2+ boots (I see petiboot menu): also I tried to boot with a USB stick connected to USB port and also in this case N2+ boots normally.

I use for N2+ 12V/4A power adaptor and I really don’t understand why this problem is happening.

Usually the boot process needs there most power, when everything is starting up, a lot of reads and writes taking place, the network gets in initialized and so on. Usually this is the part where poor power connection fails the most.
But the thing is, it would even try to boot but even this does not happen with something to USB attached which makes me think that a plugged in USB device is shortening something on the board? But on the other hand you can boot from an USB Stick, which suggests the sabrent is the main culprit and not the USB port.
Can you try to connect another HDD via USB an observer what happens? Or try another cable with the sabrent ?

Thanks Jappe for your explanation.

I am using this USB-C UBS-A cable (2m length, sorry this page is from Italian Amazon):

because Sabrent USB-C USB-A cable is too short for my needs.

Maybe to test I can move Sabrent unit closer Odroid N2+ to use Sabrent cable (it’s a complicated move but I’ll try).

At this moment I haven’t any other USB disk but next week I will try with some Sata SSD (in a Sata-USB case).

I will post my results.

Thanks again