DietPi_OdroidC1-ARMv7-Stretch to SD not working


I’ve tried to resolve this issue by Googling, but so far no solutions therefore here I am :slight_smile:

I am trying to write the DietPi_OdroidC1-ARMv7-Stretch image to a Micro-SD card to use on my Odroid C1+ but I cannot.

I have tried both Etcher as well as Win32DiskImager (under Windows 10). They seem to write the image but Odroid does not boot with it. I’ve tried 2 different Samsung SD cards as well as a Kingston.

However, when I write the DietPi_OdroidC1-ARMv7-Jessie image it does run on my Odroid.

Please can anyone confirm that the DietPi_OdroidC1-ARMv7-Stretch image does work on their Odroid C1+

Also I noticed that DietPi_OdroidC1-ARMv7-Stretch is only 71MB compressed but DietPi_OdroidC1-ARMv7-Jessie is 137MB.

Please advise. Thank you.

What you mean by “does not boot”? Note that the Stretch images based on mainline kernel do not support HDMI/screen output. Only SSH or serial consoles will work. There are some other limitations but due to lack of kernel development (manufacturer side) there is nothing we can do about it.

Yeah the Jessie image runs on the initial Hardkernel kernel version, but Debian Stretch does not run on it, thus software side support is fading, especially with Debian Buster support, which makes Jessie the oldoldstable :frowning:.

“do not support HDMI/screen output”

OK I missed this somehow, but it does explain a lot :open_mouth:

It does not show up on my network so I cannot SSH to it and since no HDMI out I do not know what is happening with the OS :frowning:
Will try again and see if a can get any further. Thanks.

Was hoping to do something useful with my old Odroid C1+ as I’ve been using DietPI on a PC and Virtual Box and I love it!

Did you simply plug it via Ethernet? That of course must work if not HDMI support is there. Most users have no serial terminal to attach.

The info about missing HDMI support (as well as the others) indeed must be added to the download page. Thanks for the hint. We discussed it widely on GitHub but of course most users do not check it first.

If I can get my hands on a USB to Serial adapter one day then I will try again.

Went back to Jessie and even Jessie says it cannot find logon folders ect. Too much to troubleshoot.

So I will use my Celeron J1900 Embedded PC for now which runs 100% or the Virtual Box version :stuck_out_tongue:

Hmm, if you can paste the exact error messages that you are facing, we could hopefully debug.