DietPi + Odroid n2+ UART not working - how to enable?

I have DietPi installed on the Odroid n2+. And want using pin 8 and 10 for RX, TX communication.
Normaly this pins are mapped as /dev/ttyAML1 but I can’t see this AML1 under DietPi. Also not under dietpi-config. How can I enable this UART ?
Thank you

maybe something @MichaIng could help with.

thanks, hope @MichaIng will read.
I also checked odroid wiki regarding UART
but really not clear for me what to do to get UART working

question is, do I need install a device-tree-compiler to configure UART or is there any other configuration too under dietpi for uart configuration?

it might not directly related to DietPi but to the kernel we use on that image. I guess some device tree overlay are needed.

makes me crazy. Before I use apt update followed by apt upgrade was ttyAML1 port working and also communication.
Don’t know what to do now to get functionality back.
Regarding odroid I found this, but not what to do :

Check out /boot/dtb/amlogic/overlay which contains some device tree overlays, including “uartA” and “uartC”. I’m not sure which one is enabled on the pins you want, respectively is attached to /dev/ttyAML1, but you can try them out.

Enable them by adding (starting with) uartA to the overlays= line in /boot/dietpiEnv.txt. No quoting or anything needed, just add an overlay right behind the = sign, or separated with a space if there is an overlay already. Generally use the filenames and remove .dtbo extension and prefix (meson- in this case).

thanks for answer.
is see this files :
so I can try “uartA” and “uartC”.
But are you sure it’s /dev/dietpiEnv.txt ?
I can’t find, but see it maybe in the boot ?
when I will open I can see :

so modify like this :

or meson with “-” ?

I tried “uartA” and also “uartC” but no luck. When it’s working I must see this ttyAML1 somewhere ?
Maybe prefix must be really “meson-” I used what was already there “meson”

A typo my end. The file you found is correct of course and edited correctly as well.

ok step by step this modification :

but still not working. In the dietpi-config I can see all ttyS1…ttyS7, also ttyAML0 but no AML1

so I added both uart :

but still not luck to get communication working
according to this :

I also tried communication to ttyS but also not working
but I know that it was ttyAML1 and it also there :
with some code for uart enabling, but I don’t know how to use and if it’s possible to use.

So to be sure, I connected usb to rs 232 adapter and ebus is working, so it’s really dietpi update problem. After update uart on the board is disabled. So now I need to get working again. I will be grateful for any help.

I’m not sure that something changed on our bash script. Probably an apt package update that incluence in this case.

When I installed dietpi first time, I did nothing. Port ttyAML1 was all the time here. So in the dietpi-config I switched on and communication on the pin 8 and 10 was working.

It doesn’t matter now, now I need to know how to activate it again

So it looks like no dietpi support for odroid n2+ onboard uart.

Why are you not using the default debug console on /dev/ttyAML0 which is present and also enabled for boot messages and with a login console by default? It’s this dedicated 4 pins connector on the PCB.

Btw, do not use the Odroid Wiki for such info, as it refers to the vendor kernel, not mainline kernel.

After enabling the device tree overlays, are there additional /dev/ttyAML* or /dev/ttyS* devices? Probably they are there and you just need to enable a login console for them.

AML0 I did not tested, because is hard for me connect to this pins and yes, there can be a some console communication which I don’t know how ebus adapter will interpret.
Which instruction to use to check actual running devices ? I will try before overlays modification and after to be able answer you correctly.

sorry don’t know what is it :roll_eyes:

uartA not added:

after uartA added :

looks it’s the same before/after

and once more edited file: