Dietpi not starting after update

Hi everyone,

I updated Dietpi on PC Lenovo Thinkcenter but after that it won’t start . Please see the attached pictures . I don’t want to lose the files :frowning: .

whatever option I chose it leads to the same error . Please help

There seems to be an issue with the grub boot loader. Not sure if we can do anything on this.

Can you have a look please. Thx

Thank you Joulinar for replaying . Waiting for MichaIng

I was able to fix the problem ! I just followed these steps :-

Thanks everyone !

EDIT: Ah lol, great that you were able to solve it already :smiley:. The underlying issue seems to be that on upgrade grub was flashed to the wrong drive. Similar to this. It seems that the underlying issue has never really been solved: The ability of the grub install script to reliably detect the correct drive it was booted from.
Hmm, doing some search:

Is it an EFI image or BIOS?

Do you have the ability at early boot to select the OS for some seconds? In this situation, hitting c should bring you into the grub command prompt. If so, it is possible to manually boot from there and then re-install grub:

Else, and probably easier, is to boot form an attached USB drive, or attach the affected broken drive to another system and repair grub from there.

Hi MichaIng . Yes I don’t imagine that I should install the whole system from the beginning :rofl: Next time I should make backup before updating

It’s BIOS . I was not able to boot the system at all . I tried through grub command prompt but also nothing change . The boot from internal hard disk