DietPi in Acer C720 Chromebook

hello, I have an acer c720 chromebook with only 2G of ram, with no possibility of expansion and onboard SSD.
not to mention the little memory, it is a great machine, I have had it for years and it is very durable, including the battery.
I would like to know if there is a step by step to install the dietpi in it. currently it is with the solus OS, but it is slow, because of the memory.
I remember that when I tried to install another debian distro I had problems with the touchpad, which did not happen with solusOS.
I recorded a pendrive with debian LXDE and managed to access it in liveUSB mode, but as I expected the touchpad had problems, although this time it worked, only the “click” function was missing.

I thank you in advance and please forgive my weak English.

PS: I forgot to say that I already installed the dietpi in one rpi4 and two rpi zero, so I have some familiarity with the system, although I am very limited technically speaking.
thanks again


many thanks for your request. Basically the base of DietPi is a Debian image. There you would need to get a Debian image running. Once done you could try to setup DietPi on top.

hello, thanks for the solution!
I would like more help, if possible. Does this script work on ubuntu systems? I have a c710, older than this c720, and has been running galliumOS for a long time. Ubuntu is “related” to debian, so I thought about that.

Thank you again.

No it’s not working with Ubuntu. You need Debian for this.

Hi, you need to remove the write protection screw inside the Acer C720 Chromebook, update the firmware from the website
After that you can install Linux (DietPi) on your Chromebook.
On the website from mrchromebox is a manual how to change the firmware.


this is nice, but very old → even me as absolute beginner can see that this script might not work properly:

apt-get died… 5 years ago?

here is the output from the first lines:

karl@chrombox:~$ wget -O
#wget -O
#wget -O
#wget -O
chmod +x
--2023-12-07 16:20:36--
Auflösen des Hostnamens (…,,, ...
Verbindungsaufbau zu (||:443 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 404 Not Found
2023-12-07 16:20:36 FEHLER 404: Not Found.

but… I mastered to install Debian… a first step for today

perhaps withon the next view days I can organize to install DietPi
many thanks

Where do you get this from? Any references.

Location of script change. See our docs Supported hardware - Docs

We don’t guarantee the script working on each and every platform/ device. It’s an option for boards we don’t support officially