DietPi for Qnap Virtualization Station 3


Is it possible to make the DietPi works on Virtualization Station 3?

Importing the images of Vmware and VirtualBox doesnt work in addition the Native PC (UEFI) doesn’t work either :face_with_raised_eyebrow:

Thank you

Hmm, QNAP doesn’t list Debian as supported OS:
Perhaps some required driver(s) is not free.

But where does boot actually stuck? It also could have something to do with UUID of the virtual drive not being important thus the bootloader looks for a drive that does not exist anymore. See:

In this case as mentioned in the link, install a clean Debian (if even possible, would be that best test to check whether the supported OS list is correct or Debian for whatever reason has just been forgotten) via removable drive installer an run the DietPi-PREP script on it to turn into DietPi.

I have Qnap TS-453Be, with Intel processor… I assume Debian is compatible with ARM Qnaps :face_with_raised_eyebrow:

Hi Folks-
I also have a QNAP running Virtualization Station and have encountered similar issues (neither the Vmware or VirtualBox images will import). In the case of VirtualBox, I received a checksum error.

I did install Debian to my QNAP (Intel proc) and attempted to run the Debian installer script. Debian installed perfectly fine to the QNAP, so I suspect the lack of Debian in the QNAP documentation was an oversight. However, I did receive an error from the dietpi installer script that the i686 architecture was not supported, and installation halted.

Any advice would be greatly appreciated.

Ah DietPi is not compatible with x32 non-ARM arch, only x86_64. This is the reason the installer fails in the first place. We already had some discussion about allowing this but it requires much work and the amount of x86 x32 systems is very low to be true…

i know out of date, when setting up in virtualization station 3, try setting the OS and computer type to generic. this is the first time i tried it, and it was a flawless install.
using the native PC bios installer, the virtual ones dont seem to work. its looking for some generic computer, thats what i fed it.

Don’t use the installer imager if you like to create virtual machine. Better to use the Direct write Image

thats what i meant, and used. i have searched and searched any noone ever posted results, i wanted to pop my skull in here and say it can be done like a charm, but the settings to watch for virtstation3 on my Qnap TS-453D (QTS5.0.1.####), anything other than using the PC-BIOS version, and setting OS type and version to generic failed on my Qnap, i have tried everything but the above settings (since i felt it had to have some base linux distro setting), and it is the first time i have had ZERO issues. it is now running pihole and nextcloud(with alot of plugins) like a flaming charm, and so much faster than on the pi4. i recently upgraded the RAM in the QNAP (see nascompares website for that) to be able to smoothly run it virtually with 4G total
EVERY single downloadable virtual image failed, installing it with MY preferred settings flawless. since i have tried it every which way to Jupiter, may find it hard to convince me otherwise, i shook this thread to show that is where i had success. not just once, i tried it several times. it worked so well for the first time, its now in deployment action. and even the wife sais, “look you finally fixed something, the network is actually faster”
yes, its deployed, but i still have the original pi with its SDD drive sitting there ready in case something goes poof. but at the moment, im able to just make a local backup of the entire virtual drive, (i tinker, ill hose it eventually, its how i learn).

on my Synology NAS, I’m using the VirtualBox image. Got them running using the import function.

Most likely the disk controller driver is missing in the initramfs of the VM images. Probably a generic VM image makes sense which includes imitramfs-tools (instead of tiny-initramfs) and hence all controller drivers OOTB. However, can you show the output of:


We should be able to identify the missing driver from the list of loaded ones when the native PC image is used.

which “dmesg” did you want, i can pipe them to text .

Just the whole dmesg

Ah sorry, it should have been lsmod, the list of loaded kernel modules which should contain the controller driver as well :sweat_smile:.

1 Like