DietPi-Drive_Manager does not mount the drive correctly

Using DietPi-Drive_Manager to mount the drive, there are no errors and fstab already shows mounted, after restarting the computer the drive is still unmounted.

UUID=f27750f9-6f6a972b8f2a /mnt/f27750f9-6f6a972b8f2a ext4 noatime,lazytime,rw,nofail,noauto,x-systemd.automount

Weclome to our community.

This is just a configuration file and is not given an information if the drive is mounted or not. For this you would need to use mount command.

The drive is configured to be mounted as soon as someone tries to access the folder. It is not done automatically on boot. Try following to see if the mound works as expected

cd /mnt/f27750f9-6f6a972b8f2a
df -h

Please ask Is it possible to mount it automatically after entering the system?

Why should this be needed? It’s mounted once needed. Did you test the behaviour as I described above?

I’ve tried the above and I can mount it but I want the disk to be mounted automatically at system boot without me having to mount it manually

Did you tried to access the directory after a reboot? Was the drive mounted automatically? There is no need to do anything manually.

I tried and I still need to cd /mnt/f27750f9-6f6a972b8f2a to see the disk

Yes this is correct and proven the automatic mount working. Same happen if other apps or processes tying to access the drive as it will trigger the same automatic mount. Therefore it’s is not needed to see the drive right after reboot. There is no benefit of having the mount available without being needed. More the other way around, as it could be slowing down the boot process if the system is waiting for the drive to become available.

Thanks, it has been solved