DietPi drive manager blank password issue!


I try to add Network Drive with blank password with DietPi drive manager. It failed because I have no password.

If I do ssh and type the line below it works but I need to redo it on every reboot!
mount -t cifs -o username=“Htpc”,password="" // /mnt/samba/aria2ng/downloads

Any solution (I don’t want to use a password on my network share and want to avoid retyping on every reboot!)?



drive manager is expecting a password. A blank one is not accepted even if your share did not require one. You can create your mount entry inside /etc/fstab yourself as drive manager is not working in your case. Btw, retyping a password is not require at. It will be stored inside /etc/fstab. Same on Windows were password could be stored for a network share.


I’m trying that.

Thank you,


In SSH I do :
mount -t cifs -o username=“Htpc”,password="" // /mnt/samba/aria2ng/downloads

In /etc/fstab I’m not to sure how to do it? What is the correct syntax?
I try to mount my Windows 10 share but not sure how…


I have some question for clarification ok before we go to change anything on /etc/fstab.

  • you have a have a W10 computer where your Media/Downloads directory is located on? A
  • And this directory you like to share?
  • Is this W10 box running 24/7?
  • This share you like to mount on your DietPi device at /mnt/samba/aria2ng/downloads?
  • Is your DietPi device running 24/7?


I have Windows 10 computer where my download directory is (//
I would like to share this directory
Windows 10 is NOT running 24/7

I would like to mount this share on my DietPi device at /mnt/samba/aria2ng/downloads
My DietPi device is running 24/7 (Raspberry Pi 3B)


well I would do it the other way around. As your DietPi is running 24/7, why not using it as SAMBA server and mount the directory into Windows? As well you could have issues if DietPi is trying to access a folder on Windows while your computer is offline. Better to have DietPi taking over this function to share the folder.

I answered your question too fast!

I have Rpi 3 with DietPi for some servers and dockers that’s one setup.

I have Windows 10 + Vmware running also DietPi (You see, it like DietPi more than Windows 10!).
So the anwser is yes, both are always on (if I need the VM), Windows 10 first then the virtual machine (when I need it on which has aria2ng).

So, if I need to download a file, I start the virtual machine… then of course Windows 10 shared folder is available because that computer is on and has the share!

I would like to download a file and save it directly on Windows 10 hard drive where my other media (instead of saving it on virtual hard disk and then moving the file). Also, I don’t want to mount the share manually everytime I start DietPi VM…

Does it make sense?
Eventually, I will installed DietPi directly instead of Windows 10… but not now and I’m afraid to loose content of both hard disk on that pc!


well quite complicated setup to start a VM just to download stuff. But it’s your choice. Personally I would have it installed on one of the RPi running anyway :slight_smile:

As drive manager is not able to handle empty password, you would need to create the mount entry inside /etc/fstab by yourself

I agree with you.

I stop doing that because I notice when running ariang on rpi 3b; temperature rise as high as 65 degrees with only 1 download with 1 segment and the temperature is only 20 degrees in my basement… Every other apps used, it rarely exceed 50 degrees. I could buy a fan for Rpi with an external hard drive and use DietPi Sync or Syncthing to transfer when my Windows 10 pc is on.

Or If I install DietPi instead of Windows 10 on my HTPC. On that computer, I have 2 hard disks with 3 partitions, can I choose which hard disk, which partition to avoid losing data. For now, I would use my 64 gb Windows 10 partition (use linux format) and leave everything else as it is (keep data and ntfs for thoses partitions and hard disks).


you can stay with your setup, no issues :slight_smile:

You can try to add following to your /etc/fstab and leave password empty

//<IP>/<Share> /mnt/samba cifs username=<user>,password=<password>,iocharset=utf8,uid=dietpi,gid=dietpi,file_mode=0770,dir_mode=0770,vers=3.1.1,_netdev,nofail,noauto,x-systemd.automount

Unusual place is within the NETWORK section

Btw. My RPi stays cool all the time. Even in installation of Bitwarden (compiling on all cores), it stays around 45°C. I’m using a case with fan

 DietPi v6.34.3 : 01:02 - Fri 12/25/20
 - Device model : RPi 4 Model B (armv7l)
 - Uptime : up 51 minutes
 - CPU temp : 37'C : 98'F (Cool runnings)
 - LAN IP : (eth0)
 - Info Text : !!! PRODUCTION SYSTEM !!!

I add this line in /etc/fstab under Network but it doesn’t work!


// /mnt/samba/aria2ng/downloads cifs username=“Htpc”,password="",iocharset=utf8,uid=dietpi,gid=dietpi,file_mode=0770,dir_mode=0770,vers=3.1.1,_netdev,nofail,noauto,x-systemd.automount

If from SSH session, I do this cmd, it works right away! What am I doing wrong?
mount -t cifs -o username=“Htpc”,password="" // /mnt/samba/aria2ng/downloads


did you tried to access the folder? like

cd /mnt/samba/aria2ng/downloads

Usually the folder will be mounted the moment you try to access it. It’s not mounted right on system start. That’s what the x-systemd.automount flag will do. As well you can have a look to journalctl to check if a mount was done. You should see something like this if the mount is working

Dec 29 17:16:57 DietPi3 kernel: FS-Cache: Netfs 'cifs' registered for caching
Dec 29 17:16:57 DietPi3 kernel: Key type cifs.spnego registered
Dec 29 17:16:57 DietPi3 kernel: Key type cifs.idmap registered
Dec 29 17:16:57 DietPi3 kernel: CIFS: Attempting to mount //
Dec 29 17:16:57 DietPi3 kernel: No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.
g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.

similar should be visible on dmesg

[ 1863.974658] FS-Cache: Netfs 'cifs' registered for caching
[ 1863.987479] Key type cifs.spnego registered
[ 1863.987494] Key type cifs.idmap registered
[ 1863.988280] CIFS: Attempting to mount //
[ 1863.988314] No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.

Hi Joulinar,

When I access the folder from SSH with cd /mnt/samba/aria2ng/downloads it’s empty!
When I go in my Windows 10 partition, files are there!?! I don’t understand that part!

I had a look at the log of journalctl
Don’t find anywhere cifs or Attempting to mount //192.168
dmesg gives me no cifs or Attempting to mount //192.168


did you reboot your system since you changed /etc/fstab?