DietPi boot scripts failed


I’ve started running DietPi instead of Raspian for my Pi-Hole setup about a week ago. Upon initial setup I ran into an issue after a power cycle where I could no longer log in. I figued the SD card got corrupted as is often the case during abrupt power interruptions, so I rebuilt from scratch. Everthing worked well for a few days without issues. This morning I needed to replace my UPS and did a proper shutdown on the Pi before pulling the power. Upon power up I was met with the same issue, unable to log in due to missing login scripts. PiHole service is also not active. I tried both the root and dietpi accounts with the same results. I did a multi pass check of my SD card before the last rebuild and had no errors, so this looks like a bug to me. I’m including the output of an ssh session which captures the behavior.

login as: root
root@’s password:

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
-bash: /DietPi/dietpi/func/dietpi-globals: No such file or directory
[[31mFAILED[0m] DietPi-Login | DietPi boot scripts failed. Skipping DietPi login scripts…

Anybody having the same issue?

Sorry for the very late reply. If you still face this issue:

Indeed the DietPi RAMdisk has no been mounted successfully. Please paste:
cat /var/tmp/dietpi/logs/dietpi-ramdisk.log