DietPI blocking ports when using VPN or wireguard

So, I’m having a nightmare here. I’ve tried it all…
Everytime when I’m using a Dietpi-vpn or Wireguard it block the ports from the torrent clients.

I said hey, I can simply add a port forword on my router. No? WELL, IT DOESN’T WORKS.
It’s something on the DietPi… the moment I turn off the VPN, the port magically works.

I don’t know what to do anymore… I’ve been trying everything, IP RULES, configs, tutorials from here, nothing works. I just wanna replace transmision with deluge.

And for some reason transmission works even if the port is closed.

This is expected with most VPN providers since they do not support port forwarding. You want traffic being tunnelled through the VPN when it’s up, so of course forwarding ports on the router, aside of the one for the VPN itself, has no effect, as the system is forced to answer through the VPN (where no one is listening).

You’d need the VPN provider to forward incoming requests on a specific port to your system. This means that you require a personal port given by the VPN provider. Most however do not support such a service/option.

This is nothing specific to DietPi, but a natural limitation when using public VPN services. If you require to use a VPN but as well require inbound requests from other peers, you need to look for a VPN provider which offers port forwarding. Expect this to be more expensive.

Did a quick search:

1 Like

After more digging, it looks like I had to use one of the default ports. This case was 1912. :slight_smile:
No port forwarding was necessary.