dietpi-backup hangs

Hi everybody, yesterday I received a notification for version update, suggesting before to run a backup.
I run dietpi-backup, selected a full backup on a nfs share already mounted. Start, a lot of output and process hangs on
/lib/modules/4.9.27+/kernel/drivers/media/rc/redrat3.ko
output stays here forever, I see 3 rsync process active, but none of them on htop as before hanging.
I looked for the exclusions file /DietPi/dietpi/.dietpi-backup-exclude (as documentation tells) but file does not exist as well as the include file, found only a .dietpi-backup-settings with inside the destination mountpoint and type of backup; tried 3 times and always hanging at this file.
Is it normal not to have the exclusions file, do I have to compile it myself putting all files where it hangs or should I find there and some other sources to copy it and paste in the right position?
BY now only way was a CTRL+C, some other fast output about chown and then exit to the blue screen with process failed notice.
Anyone has some other idea or something else to try?
Many thanks for help.
Bye

Hi,

Most likely one of the following:

  • Filesystem corruption on SD (Insufficient PSU/SD used)
  • Issue with NFS or the server during transfer of this file.

Try backing up the system to the SD card (/mnt/dietpi-backup), to see if it hangs at the same file:

dietpi-backup 1 /mnt/dietpi-backup

Also try moving the file:

mv /lib/modules/4.9.27+/kernel/drivers/media/rc/redrat3.ko /lib/modules/4.9.27+/kernel/drivers/media/rc/redrat3.ko.test

I was unable to replicate here, backup completed on RPi 3:

sent 1,154,775,166 bytes  received 565,269 bytes  7,886,282.83 bytes/sec
total size is 1,273,807,181  speedup is 1.10
 [Ok] Backup (system) Completed.

Hi Fourdee, many thanks for the support. Actually you are right, I tried to save backup as you told me, it arrives perfectly to the end. Just finished now ; might be related to server as you suggested.
Question: destination filesystem must be ext or also FAT or NTFS could be used?
Second option would be to put in a usb key and put backups there, but in this case should I format it as ext2 or ext3 or ext4?

Thank you for your opinion!

DietPi-Backup requires a Symlink capable filesystem, list:
https://github.com/Fourdee/DietPi/blob/master/dietpi/dietpi-backup#L334-L339

I’d personally go with EXT4 for backup target media.

And if you try to read in windows try
http://www.ext2fsd.com/?p=219