dietpi 7.6.2 ARMv8 64-bit image xinit: not found

On a fresh install of dietpi 7.6.2 ARMv8 64-bit image for raspberry pi 4 8GB Model and after a got to install kodi on it this happens when i try to boot it every single time . Can i get help please ?
Error : /boot/dietpi/misc/start kodi: 39: exec: xinit: not found

Many thanks for your report. Indeed I found a bug in dietpi-software which should install the X server on RPi 64-bit systems and only skip it on 32-bit systems. Please install it manually:

dietpi-software install 6

Since there is no RPi GPU accelerated Kodi package for 64-bit yet, it might not work well. Would be nice if you could report back how the native Debian Kodi (that is installed) works, we haven’t tested or got reports for a while with latest Bullseye packages.

If it doesn’t work well (fluent HD video playback), I’ll compile an own package using DRM and GLES instead of the X server (like on 32-bit) and we’ll see if that performs better.

Hi MichaIng,
Unfortunately more steps are required to make Kodi work, as on boot dietpi will complain about xterm missing. Installing it manually is not enough either, as a “xterm: no absolute path found for shell” error is returned.

how do you start KodI? Did you tried startkodi as user root?

Hi Joulinar ,
Dietpi is configured to auto start Kodi on boot, so I don’t know which command is used for that although I guess you do. root is the default user I chose when setting up Dietpi.

Could you login as root and use


. Does it give same error message?

I get a command not found error

could you have a look pls

A recent live patch should fix it in dietpi-software, but as Kodi was already installed, install the missing X server manually:

dietpi-software install 6

I guess this was already done and Kodi is failing with different error message now

xterm: no absolute path found for shell

Ah lol I should have scrolled up a little :smiley:. Okay does this work?

xinit "$(command -v kodi)" --standalone

xterm should not be attempted if the Kodi executable is there. Is it?

command -v kodi