DietPi 6.25.3 now already 3 apps need reinstall ...?

Hi there

Suddenly Sonarr and Radarr were gone and I had to reinstall them using

dietpi-software reinstall 144

dietpi-software reinstall 145

… I already knew the Issue with Jackett and regularly have to call

dietpi-software reinstall 147

to get it working again …

Why do those apps cripple themxelves? And will I have to check all the time now if they still work & reinstall them each time the apps update themselves? Kinda eery :frowning:

else: still loving the DietPi a lot! :smiley:

Please disable the internal updater for Jackett (“Disable auto update” checkbox). It is a known, still not resolved external bug, occurring in all cases where Jackett is started via systemd unit, so not related to DietPi.

But Sonarr and Radarr should not have such an issue. What you mean by “they were gone”? Did you check service status and logs before reinstalling them?

Sry, I did not check service-status nor logs, just did a restart, and Sonarr and Radarr both could not be reached through their typical webaddress … after reinstall they worked fine.
Would you mind, posting me the two commands (service status, and get logs) here, so I will make sure to first call those, before reinstalling, in case this happens again?

Thx 4 all :slight_smile:

Those 4 should give a hint:

journalctl -u sonarr | tail -20
journalctl -u radarr | tail -20
tail -20 /var/log/sonarr/error.log
tail -20 /var/log/radarr/error.log

If the last two files do not exist, probably they are called sonarr.log, radarr.log or similar, not sure currently, but there should be only one file each dir :wink:.

So great, thx a lot :smiley: