desktop not showing via nomachine on lan

DietPi v6.33.3 : 10:05 - Mon 11/30/2020
Device model : RPi 4 Model B (armv7l)

i’ve installed xfce and mate at separate times and when accessing on lan via nomachine i get the message:

" Ooops! Cannot find the default environment. Please contact your system administrator."

when i have lxde installed, the desktop shows up fine when accessing via nomachine.

is there some config specifics one needs to add/edit in order to get mate or xfce accessible via nomachine? like
starting their respective desktop manager when accessing or something?

Hi,

many thanks for your message. I tried to replicate your issue. But for me this is working well. I installed Xfce from dietpi-software and NoMachine for Raspberry (armhf) - nomachine_6.12.3_5_armhf.deb. I had no issues to connect.


Do you have a monitor connected? Maybe you can check if Xfce is starting correctly as normal Desktop?

Do you have a monitor connected?

actually no, i do not have a monitor connected.

and i have no issue with lxde & nomachine as previously mentioned.

i’m pretty sure its me/my config, just trying to narrow where this point of failure is. :wink:

this particular rpi had dietpi reinstalled this week so its a fairly clean install. it’s the 32bit version and nomachine was auto installed via dietpi.txt.

Maybe you can check if Xfce is starting correctly as normal Desktop?

well that is a good question. i’ll check that and get back to you. thanks!

hmm I did another test on an empty RPi3B+ 32bit

  1. selected Xfce as well as NoMachine from dietpi-software
  2. did not change the autostart option, still on default Manual login
  3. installation finished without issues
  4. NoMachine is working well

Can you try to uninstall Xfce as well as NoMachine, perform a reboot and install both again?

i uninstalled and reinstalled both xfce4 & noMachine.

i connected a monitor to it. xfce4 was running and i logged into the xfce4 desktop via noMachine with no issues. so far so good.

if i shutdown, disconnect the monitor, boot going headless, cannot access desktop via noMachine. i get that message about
“Cannot find the default environment. …”


the /var/log/Xorg.0.log had one of these message lines:

  (EE) Fatal server error:
  (EE) no screens found (EE)

i uncommented this in /boot/config.txt

  
   hdmi_ignore_hotplug=1  
   
   i edited these as that's the rez i want with noMachine from a laptop:
   
     framebuffer_width=1440
     framebuffer_height=900

i did see an option for headless in dietpi-config under display resolution but i had already edited the /boot/config.txt. i assume it does the same thing?

i don’t understand why lxde worked as headless but xfce4 wouldn’t without the /boot/config.txt “hdmi_ignore_hotplug=1” edit.

anyways, it’s working now. thanks for your time and help!!! as always you folks got me running in no time!


**note: not related to my original post, but i noticed when executing the ~/Desktop/.desktop icons they timeout with error. the same dietpi-.desktop files that they are linked to in /usr/share/applications/diet-*.desktop, when executing from main menu Applications->System, they execute as expected. no biggie.

ok good that it is working now. But indeed strange behavior.

Regarding the desktop icons. This is a know bug in combination of XFCE 4.12 and Thunar 1.8

https://dietpi.com/forum/t/xfce-desktop-shortcuts-to-apps-dont-work/4605/4

thanks for the link regarding the xfce bug & fix.

ok I will mark this topic as solved for now :slight_smile: