Deluge Plugins on Dietpi

Hi Everyone

Has anybody managed to install plugins in Deluge successfully? No matter what I try and I can’t get them to install. I am using

  • Raspberry Pi 4

  • Clean install of DietPi v7.9.1(beta) - also tried the current standard release

  • Deluge 2.0.3 is installed

  • Python 2.7.18 and Python 3.9.2

When I try and install through the UI it states uploading plugin, the progress bar shows about 10% then fails.

I have tried copying the eggs to /mnt/dietpi_userdata/deluge/.config/deluge and rebooting still no joy.

Any suggestions.


Can you show the service logs, please:

journalctl -u deluged -u deluge-web

Hi MichaIng

I assume you only want the logs from when trying to install a plugin - they are attached here. Let me know if you want anything else.

all_logs.txt (5.41 KB)

builtins.TypeError: findCaller() takes from 1 to 2 positional arguments but 3 were given

This is a known bug in Deluge up to v2.0.3, fixed for v2.0.4:
Indeed even that it is >2 years ago, Deluge v2.0.3 was released before this commit got merged:

You can manually apply this change to your /usr/lib/python3/dist-packages/deluge/

Actually I would have expected that this got backported to Debian’s Deluge package since it is a known bug for more than two years. But indeed it has been reported not to long ago to Debian’s bug tracker:

I just gave this bug report a bump, let’s hope the patch will be applied soon to the Debian Bullseye Deluge package.

@michaing - thanks for looking into this - the errors have stopped been logged now.

Unfortunately the plugins still won’t install, still doing exactly the same as it was before but with no errors been logged now.

Think I will look later at moving to an alternative to Deluge.


Ignore me, it is working now with a manual install of the plugins to /mnt/dietpi_userdata/deluge/.config/deluge/plugins

Obviously renaming to .py3.7.egg for each is required as well.


There are no Python 3.9 eggs available, yet? However good when manually renaming works :slight_smile:.

Means installing them via GUI still does not work?