Deluge cannot download to Samba CIFS share

I installed dietpi and added deluge and motioneye…

I then added samba mounts through the UI

I am not able to download to the Samba shares.

If I change the download folder to the /mnt/dietpi_userdata/downloads then it works fine!

It is also not working to record movies in motioneye to the SAMBAs


I have a temp solution…

I went into the fstab file and changed:




then ran

mount -a

as a temp solution!

Sounds like the user Deluge is running under does not have permission to write to the Samba share in question.

Edit the samba config file and give the relavent user access to the share. Restart the samba service.

Can you give an example.

My share is at
My DietPi has mounted the share at /mnt/NasTorrents

So what should I look for in the smb.conf?

Here’s a segment of my conf:

client min protocol = SMB3

workgroup = WORKGROUP
server string = %h server
dns proxy = no
log file = /var/log/samba/log.%m
max log size = 1000
syslog only = no
syslog = 0

panic action = /usr/share/samba/panic-action %d

security = user
encrypt passwords = true
passdb backend = tdbsam
obey pam restrictions = yes
unix password sync = yes

passwd program = /usr/bin/passwd %u
passwd chat = Enter\snew\s\spassword:* %n\n Retype\snew\s\spassword:* %n\n password\supdated\ssuccessfully .
pam password change = yes
map to guest = bad user

load printers = no
use sendfile = yes

hosts allow =


socket options = TCP_NODELAY

usershare allow guests = yes

comment = HD
path = /mnt/usb_2
browseable = yes
read only = no
create mask = 0775
directory mask = 0775
valid users = root
guest ok = no
writeable = yes
public = yes

Edit the path to suit. Make sure you have assigned a password to the user concerned and add the name to the valid user list.

smbpasswd -a username

I did a dirty trick… you could do the same.

On the host (the one that has the USB-disk plugged in) I would do this:

chmod -R 777 /mnt/usb_2/ *

This will give permissions to every user to write to the samba share. Assuming you’re on a private network with a router firewall you’ll be fine.