DDNS update test failed (DuckDNS)

Creating a bug report/issue

Required Information

  • DietPi version | cat /boot/dietpi/.version
  • Distro version | echo $G_DISTRO_NAME $G_RASPBIAN
  • Kernel version | uname -a
Linux DietPi 5.10.123-meson64 #22.05.3 SMP PREEMPT Wed Jun 22 07:23:04 UTC 2022 aarch64 GNU/Linux
  • SBC model | echo $G_HW_MODEL_NAME or (EG: RPi3)
Odroid C4/HC4 (aarch64)

Additional Information (if applicable)

  • Software title | (EG: Nextcloud)
  • Was the software title installed freshly or updated/migrated?
  • Can this issue be replicated on a fresh installation of DietPi?
    I think so

Steps to reproduce

  1. open dietpi-ddns
  2. select “DuckDNS” as the provider
  3. enter yoursubdomain.duckdns.org as the domain
  4. enter and confirm token
  5. select “Apply”

Expected behaviour

  • DDNS update test succeeds, cron job enabled

Actual behaviour

  • DDNS update test fails
DDNS update test failed, please check your input:                                                                    │ 
curl: (22) The requested URL returned error: 400 

Extra details

I tried searching to see if I was just configuring something incorrectly, but couldn’t find anyone else with this issue. In the case that this is user error, it would be helpful to have a bit more documentation around what exactly needs to be entered in each field to correctly configure DuckDNS.

Thanks in advance for your time and advice!

Update: I was able to resolve this issue by selecting “Remove” to clear existing DDNS settings, and then going through the configuration process again.

I’m not sure exactly what the issue was with my config before, but hopefully knowing that will be helpful for anyone in the future that runs into this error

1 Like