CUPS printing on Pi4 not available from windows

I installed CUPS from dietpi-software and installed my printer driver. I can print from my phone on android but when I try from windows PC the printer is show but just hangs on “connecting” . Any help appreciated please.

Required Information

  • Distro version | bullseye 0
  • Kernel version | `Linux DietPi 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr 3 17:24:16 BST 2023 aarch64 GNU/Linux


  • Architecture | dpkg --print-architecture
  • SBC model |
    RPi 3 Model B (aarch64)
  • Power supply used | (EG: 5V 1A RAVpower)
  • SD card used | (EG: SanDisk ultra)

Additional Information (if applicable)

  • Software title | Cups(
  • Was the software title installed freshly or updated/migrated? Fresh Install
  • Can this issue be replicated on a fresh installation of DietPi?
    ← If you sent a “dietpi-bugreport”, please paste the ID here →
  • Bug report ID | echo $G_HW_UUID

Hi Filled in as much as I can. Printer is Ricoh SP213 w and everything works OK via Android but windows (on 2 systems) hangs for ages “connecting” then says something like too many connectionsn

Hello, what printer do you use and can you please fill out the trouble shooting template to gain more info about your system!?

Hi Filled in as much as I can. (See original post) Printer is Ricoh SP213 w and everything works OK via Android but windows (on 2 systems) hangs for ages “connecting” then says something like too many connectionsn

it doesn’t look like a server issue if it is working fine on your mobile device. Anything on CUPS logs?

Where do I find CUPs logs on DietPi please?

You could check service log

journalctl -u cups

Or have a look to /var/log/cups. On a default setup, logs are cleared on hourly basis.
If needed increase log level within /etc/cups/cupsd.conf

1 Like

Im having no sucess with this at all. I have uninstalled /reinstalled Cups., reflashed the SD card witha new copy of Dietpi and installed again from scratch. What am I missing ? Shouldnt it just work? Windows just cant see the printerand now I tried setting the Cups config to “defaults” and that has locked me out of the GUI all together. I just dont know where to go from here. I tried journalctl - u cups but that didnt show anything. Im not experienced with linux so thought Dietpi would be a good way to go but Im baffled.

for me this sounds more an issue wich your client and not something with CUPS. I did a test on one of my demo system and was able to create a fake printer, which was automatically detected by my W11 system. As well test prints succeeded.

Hi Thanks for your reply. If this is a client issue it is affecting TWO Windows 11 PC’s I’ve tried. One is a brand new unit with a clean new install of Win11. Both detect the printer but neither will connect to it. Like you I created a fake printer and the same issue .
Anything more I can try ?

Try to add the printer manually and not through the automatic under W11. I tested the following guide and it was working ootb Making Windows 10 to print to a CUPS printer over the network – Janne's Tech Blog

1 Like

Great thanks for the link. I was indeed an issue with Win11. Adding manually is not so easy in Win11 unfortunately. I followed this link: How to add Cups Raspberry PI printer to Windows 10 quick tutorial - YouTube and got it working.
Thanks for your patience.