CUPS - Printer "Status unavailable"

Hi,

I’ve tried to share a label printer on CUPS over my network so everyone can print from their windows 10 machines to it.

I’ve got a dot matrix printer connected to it which seems to connect fine, haven’t tried printing anything to it yet as unsure how but it connects.

I’ve also got a network printer I’ve re-shared over CUPS which is printing fine as well

My issue is that I’ve got a Zebra ZD420D connected to CUPS via USB and shared it and every time I go into windows and select it then it says “Connecting” and then changes to “Status unavailable”.

Any ideas what could be causing that? Thank you!

Hi,

many thanks for your message. I guess your printer is not supported on Debian based OS

https://www.zebra.com/us/en/support-downloads/knowledge-articles/mac-linux-or-unix-driver-suggestions-for-zebra-printers.html

Probably you need to contact Zabra support to get clarity.

Hi,

Thank you for the reply, the ZD420D is capable of EPL 2 and ZPL 2 printer languages which CUPS also supports so I can’t see there being an issue on that front

sorry I can’t say more than stated on the manufacturer web site. There is no support for Debian listed.