Cuberite and MineOS giving errors during install

I’m using the latest DietPi version 8 on a Raspberry pi 4 but can’t seem to get Cuberite nor MineOS to work.
During install I get:

[FAILED] DietPi-Services | restart : cuberite

So I try running systemctl status cuberite.service which gives me

Starting Cuberite Server (DietPi)...
cuberite.service: Failed to execute /mnt/dietpi_userdata/cuberite/Cuberite: No such file or directory
cuberite.service: Failed at step EXEC spawning /mnt/dietpi_userdata/cuberite/Cuberite: No such file or directory
cuberite.service: Control process exited, code=exited, status=203/EXEC
cuberite.service: Failed with result 'exit-code'.
Failed to start Cuberite Server (DietPi).

The folder and file is there though when checking it.

During install I get:

    - Command: ./
    - Exit code: 1
    - DietPi version: v8.0.2 (MichaIng/master) | HW_MODEL: 4 | HW_ARCH: 3 | DISTRO: 6
    - Image creator: DietPi Core Team
    - Pre-image: From scratch
    - Error log:
 Script execution started on: Sun Jan 16 18:18:00 GMT 2022
 Updating mineos-node repository...OK
 Pulling master branch...hint: Pulling without specifying how to reconcile divergent branches is
 hint: discouraged. You can squelch this message by running one of the following
 hint: commands sometime before your next pull:
 hint:   git config pull.rebase false  # merge (the default strategy)
 hint:   git config pull.rebase true   # rebase
 hint:   git config pull.ff only       # fast-forward only
 hint: You can replace "git config" with "git config --global" to set a default
 hint: preference for all repositories. You can also pass --rebase, --no-rebase,
 hint: or --ff-only on the command line to override the configured default per
 hint: invocation.
  * branch            master     -> FETCH_HEAD
 Updating npm dependencies...npm WARN old lockfile
 npm WARN old lockfile The package-lock.json file was created with an old version of npm,
 npm WARN old lockfile so supplemental metadata must be fetched from the registry.
 npm WARN old lockfile
 npm WARN old lockfile This is a one-time fix-up, please be patient...
 npm WARN old lockfile
 npm ERR! code 1
 npm ERR! path /mnt/dietpi_userdata/mineos/minecraft/node_modules/posix
 npm ERR! command failed
 npm ERR! command sh -c node-gyp rebuild
 npm ERR! gyp info it worked if it ends with ok
 npm ERR! gyp info using node-gyp@8.4.1
 npm ERR! gyp info using node@17.3.1 | linux | arm64
 npm ERR! gyp info find Python using Python version 3.9.2 found at "/usr/bin/python3"
 npm ERR! gyp http GET
 npm ERR! gyp http 200
 npm ERR! gyp WARN install got an error, rolling back install
 npm ERR! gyp ERR! configure error
 npm ERR! gyp ERR! stack TypeError: tar.extract is not a function
 npm ERR! gyp ERR! stack     at go (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/install.js:164:15)
 npm ERR! gyp ERR! stack     at processTicksAndRejections (node:internal/process/task_queues:96:5)
 npm ERR! gyp ERR! stack     at async install
 npm ERR! gyp ERR! System Linux 5.10.63-v8+
 npm ERR! gyp ERR! command "/usr/local/bin/node"
 "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
 npm ERR! gyp ERR! cwd /mnt/dietpi_userdata/mineos/minecraft/node_modules/posix
 npm ERR! gyp ERR! node -v v17.3.1
 npm ERR! gyp ERR! node-gyp -v v8.4.1
 npm ERR! gyp ERR! not ok

 npm ERR! A complete log of this run can be found in:
 npm ERR!     /root/.npm/_logs/2022-01-16T18_18_01_771Z-debug-0.log

Not sure how to get either of them working at this point.

can you share some more information

Required Information

  • DietPi version | cat /boot/dietpi/.version
  • Distro version | echo $G_DISTRO_NAME $G_RASPBIAN
  • Kernel version | uname -a
  • SBC model | echo $G_HW_MODEL_NAME or (EG: RPi3)
DietPi version :

Distro version:
bullseye 0

Kernel version:
Linux DietPi 5.10.63-v8+ #1488 SMP PREEMPT Thu Nov 18 16:16:16 GMT 2021 aarch64 GNU/Linux

SBC model:
RPi 4 Model B (aarch64)

The issue with Cuberite seems to be related to the application themselves. We use pre-compiled binaries, directly provided by Cuberite. What is working is to compile it from source. I ask our developer to have a look and confirm the issue with the Cuberite binary.

Btw: 32bit is working fine.

MineOS seems to have other issues with Python. Needs further investigation. Looks like it require Python2 which is depreciated.

Thank you for taking the time to check these issues. I will keep an eye on the github issues and hopefully they will be solved in the future.