Connect an ESP via ttyAMA0 - Pi 5

I am trying to connect an ESP radio Modul via ttyAMA0 to my raspberry pi 5. The ttyAMA0 seems not be running.

What I have tried:

  1. Deleting “console=serial0,115200” from the cmdline.txt
  2. added to the config,text: enable_uart=1, dtoverlay=miniuart-bt, force_turbo=1

But no luck. It does not work. At raspbian it does work.

I guess it has something to do with the ttys0 and ttyAMA0 console. At dietpi-config both are not available anymore.

Any suggestions?

Thank you.

were you doing it as sudo or as user?

Might need to add the user to the group that uses that tty or USB port
are you attempting something like this?

EDIT: The following descriped problem might be based on a wrong documentation of the raspberry foundation regarding the raspberry 5 uart.

tried everything, but did not work.

Maybe has something to do with this information from the documentation of the new rasbian:

“Unlike previous Raspberry Pi models, where you could enable a serial console on GPIO14 and 15, enabling a serial console from raspi-config will enable a serial console on the new UART connector on /dev/ttyAMA0 on Raspberry Pi 5.”


“The Raspberry Pi 5 has a dedicated debug UART connector. It has a maximum baud rate of 921,600bps, which can be configured with an EEPROM parameter. It is always active and enabled, and provides direct access to early boot and firmware information; as well as a Linux console after boot.”

But funny with rasbian I could start ttyAMA0 at the pins 14 and 15. But with dietpi I am going crazy…

within the folder /dev is no ttyS0 file. This might be the problem. Solutions?

Furthermore, there is a missunderständing. I am using an Enocean-Modul ESP