Completely remove Sabnzbd

I briefly installed sabnzbd with DietPi before deciding to run it on my NAS instead. I installed it and removed it with dietpi-software, yet I still have an sabnzbd process running. I’ve tried installing/uninstalling again, but the process is still there. I must have done something manually because sab required python 2.7 instead of 3, but I don’t know how to reverse it. What is the proper way to remove this completely?

root@DietPi:~# ps aux | grep sab
sabnzbd   1573  0.8  0.9 248260 37012 ?        Ssl  10:33   0:03 /usr/bin/python2.7 -OO /etc/sabnzbd/ -b 0 -f /etc/sabnzbd/sabnzbd.ini


did you reboot your system after removal? Usually all these thinks should be removed. What version of DietPi you are running?

I’ve rebooted a few times for the HomeAssistant issue you’ve also been helping me with. Removing sabnzbd isn’t a huge priority right now; it’s something I noticed while I was waiting for docker setup to finish. I am on 6.34.1 beta now. I vaguely remember having to do something manually when I first started using DietPi last year because sab was still on 2.7 and DietPi was on 3, but I don’t remember what I did or how to reverse it. Documentation is always the bane of my existence, whether it’s with computers, recipes, or changing the oil on my car :slight_smile:

basically these are the removal steps according dietpi-software

systemctl disable --now sabnzbd
rm -R /etc/systemd/system/sabnzbd.service*
rm -R /etc/systemd/system/sabnzbd.service.d
getent passwd sabnzbd > /dev/null && userdel sabnzbd
getent group sabnzbd > /dev/null && groupdel sabnzbd # Pre-v6.33
rm -R /etc/sabnzbd
rm -R /var/log/sabnzbd

That worked, thank you!