Hi there,
I’ve just made the transition from the Stretch version of DietPi to the Buster version. The only thing I’m struggling with is cloud print. I cannot get my Canon Pixma MP510 installed. It worked perfectly on Stretch, but I don’t seem to be able to install my printer in the Buster version. Canon printers do not seem to be listed anymore. Any idea what I’m doing wrong?

Ok, I’ve been doing some investigation. It appears its a Buster thing. I’ve just installed a Debian Buster Virtual Machine on my Mac and was unable to connect to my printer (Canon MP510). However I did manage to get it to work by following these steps

  1. Visit
  2. Follow the link to download the UFRII LT Printer Driver V 5.00 -
  3. Extract the download and run

Install the printer from the sytem preference
Now this all works on Standard Debian Buster. I tried following these instructions on my Pi, but the drivers are for i386 and not armhf

Can these drivers be ported to armfh? Can anyone help me do this or extract the drivers from the Stretch version of DietPi?

Ok, I’ve managed to install the print driver using

apt-get install printer-driver-gutenprint

and I can print a test page through CUPS. But I cannot see the printer on the network or via AirPrint?

Any ideas please?

I’ve now managed to get air print installed on Dietpi and my Mac and iOS devices can now print.
I followed the instructions on this page:

Just out of interest, any idea why Airprint is not included with cloud print by default now. It used to be with the Stretch version.