Chromium in ARMv6 release


I’d like to ask if it’s possible to put Chromium back in to the ARMv6 release. I’d like to use DietPi as WebKiosk on a Raspberry Pi Zero W.
I know that Chromium browser can run on ARMv6, since it’s working with Raspbian with no problems on the same device.

Why was it taken out from the ARMv6 release? Is it possible to put it back?

Thank you for the answers in advance.

Hmm not sure why we took it out actually. Especially since Stretch we simply install the APT packages, so as long as they do not prompt an error message, they should work fine.

Please try do unlock it manually: nano /DietPi/dietpi/dietpi-software
Search for the first match of “software_id=113” (ctrl+w for searching)
Remove the line “aSOFTWARE_AVAIL_G_HW_ARCH[$software_id,1]=0” from this section.

  • For this navigate to the line via arrow buttons and press ctrl+k.
  • Then press ctrl+o to save and ctrl+x to exit.
    Then retry the install.

Opened an issue on GitHub:


On this subject, I really like that I can run Chromium in Kiosk mode from a simple X session (even more now that I have worked out how to add a Scrapping VNC server on top).

There’s just one thing I can’t see to get working, if someone would be kind enough to point me in the right direction.

The openHAB interface that I use has a feature where any web interface is an “Audio Sink”, meaning that sound files can be pushed to the browser for local playback.

This has worked really well in every platform that I have tried, but I just can’t get any sound at all out of Chromium in DeitPi, on an Odroid C2, with the Odroid 7 inch multi touch HDMI screen, with their speakers attached.

The dietpi-config audio menu shows the HDMI audio hardware (granted without any options) so I assume it’s okay.

I have tried connecting a USB audio device, so maybe I can route the sound to that, but I guess Chromium still needs to handle it properly.

Is there more information I can give that will help someone help me, or is there something I can try…